[lkml]   [1997]   [Jan]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Compiling woes..

> I just downloaded 2.1.21... configured it and tried to make it... and i got
> errors durring the depend stage.. .complaining about module.h and how it
> should include config.h but dosent... then it continues on to yell about
> genksyms... it gives me a usage error... so I went and downloaded a fresh
> 2.1.21, a fresh modules-2.1.13 and tried to compile the module package and

There's your problem.. Check out Changes in the Documentation
Directory.. latest version of Modules should be the snapshot from 970104. the
modules structure changed in 2.1.18, making the modutils from 2.1.13 useless.
after that you should be fine.. I received the same warning about module.h
during make dep, but it compiled fine for me.. just rebooted to it right now..
recompile Modules, and you should be set.

Brad Littlejohn | Email:
Unix Systems Administrator, |
WebMaster, NewsMaster.. Smeghead! :) |
PGP: 1024/E9DF4D85 67 6B 33 D0 B9 95 F4 37 4B D1 CE BD 48 B0 06 93

 \ /
  Last update: 2005-03-22 13:38    [W:0.022 / U:0.228 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site