[lkml]   [1996]   [Sep]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: IP-alias problem
On Thu, 5 Sep 1996, Nicolas Lichtmaier wrote:

> I run a BBS with several diskless-nfsroot mounted-floppy booted-machines
> with internal modems. They get their IP address by querying "zaratustra"
> (what a name!). IP= [bootptab snipped]
> When I set up an alias for eth0 (ifconfig eth0:0 to host a
> "virtual WWW server" this is what happens:
> us? says that "" replied and, ignoring the bootp fields TRIES TO
> MOUNT FROM nfsd/mountd ignores such a request and booting
> fails.

Somewhere between 1.3.91 and 2.0.10, the code for choosing the route device
when an IP alias existed was changed. I had a similar problem where packets
were going out with the wrong IP address, route was using eth0:0 instead of
eth0. Changing the route statement in rc.inet1 to explicitly specify 'dev
eth0' fixed it for me.

Sorry, cannot help with the wrong NFS mount problem.

 \ /
  Last update: 2005-03-22 13:38    [W:0.039 / U:0.012 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site