lkml.org 
[lkml]   [1996]   [Sep]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Floppy not working w/2.0
Date
From

>
>Hello!
>
>I've got a problem w/my floppy drive. It works fine on 1.2.13 with
>the same floppies, but not on 2.0.10, 2.0.17 (and I think 2.0.13 also).
>The symptoms has been the same on all of the 2.0 kernels.
>
>The problem exists w/tar, dd, and mdir. They all return info like:
> $ mdir
> floppy0: long rw: 16 instead of 12

What this means is that somehow the floppy drive reads more data then
instructed by the driver.

[...]
>
>One other interesting thing to note. When the AC power is attached
>the BogoMIPS are double than w/o AC (53.04 vs. 25.34). I assume
>this is just because the HW is going into power saving mode, no problem.

This may indeed be interesting. Indeed, the amount of data to be
transferred is communicated to the DMA controller, and not directly to
the floppy disk controller. The DMA controller signals the end of the
transfer to the floppy disk controller when enough data has been
transferred.

Now, power saving mode has sometimes strange side effects. On some
Laptops, DMA transfers are suspended when the CPU is halted. It may
well be possible that on your laptop the "end of DMA transfer" line is
disabled in power saving mode, which would lead to a "never ending"
DMA transfer.

Does the problem also happen when the laptop is attached to AC power?

You may also disable floppy DMA by giving the option "floppy=nodma"
to LILO when booting. With this option, the floppy driver uses port
I/O to transfer the data, and this method is probably not affected by
this problem.


Regards,

Alain

\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.039 / U:3.000 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site