lkml.org 
[lkml]   [1996]   [Sep]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Prerelease of 2.1.0
Ok, I've tried the 2nd pre-release of 2.1.0, and this time it booted
just fine using Loadlin (many appologies for my hasty comments about
Loadlin not working). The kernel itself works fine, but everything
involving modules is DEAD. This included sound.o, serial.o, msdos.o,
etc... /proc/modules showed all loaded modules as "(uninitialized)". Is
this a result of modprobe (and insmod) expecting kernel adresses to be
aligned with hardware adresses, or is it something to do with the module
initialization code? I recompiled with all my normal drivers compiled
into the kernel, something I never do since it is usually just a waste
of precious RAM. This time, everything works just fine... msdos,
serial, ppp, etc... I am using an AMD 5x86 133 (486), and in general
this 2nd pre-release of the new kernel seemes to work fine (except for
all modules being dead, dead, dead)
-Erik

--
Erik B. Andersen Web: http://www.et.byu.edu/~andersee/
2485 South State St. email: andersee@et.byu.edu
Springville, Ut 84663 phone: (801) 489-1231
--This message was written using 73% post-consumer electrons--



Linus Torvalds wrote:
>
> On Tue, 24 Sep 1996, Hans-Georg von Zezschwitz wrote:
> >
> > SMC Ultra is fine running 2.1.0
>
> Thanks for the report..
>
> > Another report about speed:
> >
> > Recompiling a clean pre2.1.0-tree with my configuration took:
> >
> > using Linux 2.0.21:
> > 554.28user 36.98system 10:18.67elapsed 95%CPU (0avgtext+0avgdata
> > 0maxresident)k
> > 0inputs+0outputs (0major+0minor)pagefaults 0swaps
> >
> > using Linux 2.1.0:
> > 553.11user 36.07system 10:15.06elapsed 95%CPU (0avgtext+0avgdata
> > 0maxresident)k
> > 0inputs+0outputs (0major+0minor)pagefaults 0swaps
> >
> > Well, that's 0,6%. Of cause, I can't claim that my single pass test
> > has any relevance. Who Bever thinks, that this is very little, should
> > consider that the German magazine c't was already delighted when
> > Maple ran 10-15% faster using Linux instead of Windows.
>
> Well, to be quite frank, I didn't expect all that much of a speed increase.
> After all, the segment override stuff is generally just a few clock cycles,
> and you end up spending more time just waiting for memory anyway (unless you
> have a slow machine, and then you have a slow machine ;)
>
> Also, I haven't actually gotten rid of the %fs stuff - I'll be able to shave
> off a few ten clock cycles off the kernel entry routines by not having to
> load %fs (and making "get_fs()"/"set_fs()" work like they do on the alpha).
>
> But more important than the potential speed advantage (which is likely to
> become more marked on newer CPU's) is the fact that I got rid of maintaining
> a lot of inline assembly (look at <asm-i386/segment.h> before and after the
> operation), and that the new setup works the same way on x86 (the bread and
> butter of the Linux world) as on most other ports.
>
> I'll try to produce better numbers (your differences are definitely within
> the error limits),
>
> Linus

\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.092 / U:2.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site