lkml.org 
[lkml]   [1996]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectV 2.0.6 and IDE errors
I count 8 linux-kernel messages in my News spool (14 days) that refer to
IDE disk problem (obtained by: egrep -l read_intr /usr/spool/news/linux/dev/kernel/* | wc).

Now call me Dr Paranoid but I just tried installing Debian GNU/Linux 1.1
on a couple of partitions of a Compaq LTE 5100 machine that has a 1.2
Gbyte Toshiba drive. The machine had worked fine (old Slackware 3.0,
only X had expired) until the upgrade, then very soon after (before I
had really finished the installation) I get a lot of the IDE
Unrecoverable errors. I have four partitions on the drive (DOS, /, swap
and /home on hd[a-d] respectively), and thinking it was a dud partition
I wiped /home with another attempt at installation. As soon as I tried
reasonable disk activity (i.e. an emacs while the standard FTP access
was installing) I get IDE disk errors and file system corruption.

Now I can think of four things:

1) the disk was shot and it was purely coincidence that it happened at
upgrade time (twice...).
2) the 2.0.6 (I think) standard (stable) debian kernel has a problem -
perhaps because it doesn't enable some bug fixes or whatever.
3) there is a real problem here as Linux can make use of an IDE
controller more efficiently than DOS so exercise more bugs.
4) none of the above.

Yes, I saw this problem first time with "/" but I wanted some debugging
info and so sacrificed my /home partition. Now DOS format can't cope
with "/" (it just gives up) so I guess I need a new drive (it is only 10
months old). DOS format only found one bad block with the old "/home",
but this is what I saw last time and ignoring it for a day or so
resulted in an unformatable partition (I guess on the second attempt I
caught it in time - I stopped on the first IDE error). I now seem to
have lost most of my disk, and don't have a portable to take with me
anymore.

Sorry I can't provide more information - the machine is no longer on the
net...


Tony Robinson

\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.128 / U:1.192 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site