lkml.org 
[lkml]   [1996]   [Sep]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectHaving a problem w/ procps 1.01 & kernel 2.0.xx

I had jumped from slackware 3.0 (1.2.13 / 1.3.8 kernel) to the new
2.0 version of Linux. I am currently running kernel version 2.0.20.

I have gone through the documentation on how to upgrade from 1.2.xx versions
of the linux kernel to the latest and greatest 2.0.xx version. This is the
document found inside the kernel source archive (linux-2.0.20.tar.gz) when
expanded, the pathname I have it at is /usr/src/linux/Documentation/Changes.

Since I had upgraded from a Slackware 3.0 install, the document stated that
everything should be okay if I get the new versions of the programs listed in
the document.

If I am running a procps package less than 1.01, I am supposed to get
Floating Point Exceptions on some 'ps' options... I upgraded
my procps package to the latest 1.01 distribution but I am getting
Floating Point Exceptions whenever I do a 'ps -uax' command. Using
'ps -ax' or just 'ps' works just fine to this date... Here is the exact
screen dump of when I run the command 'ps -uax':

river:/ # ps -uax
USER PID %CPU %MEM SIZE RSS TTY STAT START TIME COMMAND
Floating point exception
river:/ #

When I run 'top', it has no problem displaying the user PID, user, PRI, NI,
etc... fields - only a problem when 'ps' tried to display the user field.

If any other information is needed, like some kernel-booting messages
or other various pieces, please let me know.
I would appreciate any 'constructive' opinions/solutions for this
problem, since I try to use 'ps -uax' a lot.

Thanks a bunch!


/\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\\//\
\|/ John Harms - Student (Junior), Central Michigan University
o o |-- Email: harms@cps.cmich.edu --> harms@cc.cst.cmich.edu
v |-- RIVER email: harms@river.emmons.cmich.edu
- |-- Owner and System Administrator of river.emmons.cmich.edu
/|\__/|-- Employee of the Pearce Computer Center, Central Michigan Univ.
\| |-- Fall 1996 Intern. Office: Pearce 422.
| `-- Also webmaster@cps.cmich.edu, webmaster@cc.cst.cmich.edu
/ \
------------------------------------------------------------------------------


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.022 / U:5.268 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site