lkml.org 
[lkml]   [1996]   [Sep]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: National Semi 87306 IDE support

On Sat, 14 Sep 1996, Edward Welbon wrote:

> Is this chip supported? I can't get better than 1.5MB/s with a 1.6G WD
> IDE. hdparm is not able to set DMA active, an error occurs if I do hdparm
> -d1 /dev/hda. I get HDIO_SET_DMA failed: Operation not permitted.
> I tried setting "ide0=autotune" but this did not help. Suggestions?
> While I am running 2.0.20, this has occured on all the 1.3 and later
> kernels I have tried.

I took a look thru the ide driver source (2.0.20) and saw no special
mention of the chip. I have seen lots of problems with the large (<850MB)
WD drives, in terms of both performance and reliability. I booted a
friend's system with this drive and a generic VLB controller, and got
1.45MB/sec, so i really doubt its the controller (an older quantum drive
in that same system gets 2.5MB/sec). I'd suggest trying a different
drive, prefereably one that benchmarks significantly faster in somebody
else's Linux system. I have a quantum Scirroco 1.7gig that gives
5.5MB/sec under DMA (Triton II) and 4.5MB/sec under PIO4. It managed
about 2.4MB/sec under PIO3 on my old motherboard (with a buggy CMD640A).

Simon Karpen
karpes@rpi.edu
slk@karpes.stu.rpi.edu
--
Note that lnxkrn@karpes.stu.rpi.edu is an address that I use just for
recieving Linux-related mailing lists so that I do not fill up my mailbox
with them.


\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.039 / U:1.780 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site