lkml.org 
[lkml]   [1996]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: undefined symbols in 2.0.19
Joshua E. Hill wrote:
>
> I recently tried out v2.0.19 and found that several of the modules
> had unresolved symbols. The modules/symbols are:
> /lib/modules/2.0.19/scsi/scsi_mod.o
> down_failed
> up_wakeup
> /lib/modules/2.0.19/scsi/sr_mod.o
> down_failed
> up_wakeup
> /lib/modules/2.0.19/block/floppy.o
> up_wakeup
> /lib/modules/2.0.19/block/loop.o
> up_wakeup
>
> I looked around and found the symbols in <asm/semaphore.asm>.
> I tried including it into the various drivers, but it didn't seem
> to work.

I'll second this problem. The usual solution of placing:

X(down_failed),
X(up_wakeup),

in ksyms.c does not do the trick with symbols in asm modules. I'm
afraid my low-level hacking abilities with the unix assembler are not up
to this one :-(.

Steve

\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.043 / U:2.732 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site