lkml.org 
[lkml]   [1996]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectProblems with large ext2 fs in 2.0
Date
After a total failure of a disk in my news server last week, I had to
reinstall the entire system. As the news server had previously been an
(old) Slackware system running INN, I decided to try Slackware96 for this
one.

Everything went smoothly, although I had some problem with nnrpd from
the current kit and replaced it with an old one.

BUT - I'm now getting regular FS corruption - illegal and duplicated blocks -
all over one of the file systems - a 2G ext2 partition. There are no
disk errors logged. Multiple fsck runs seem to keep finding bitmap
differences - which strongly suggests a hardware problem.

fsck is e2fsck 1.04, 16-May-96 for EXT2 FS 0.5b, 95/08/09

The kernel is Linux 2.0 (as distributed with Slackware 96).

The disk is a 2G IDE drive. There's another 1.2 G drive in the system,
with a 1G ext2 FS on it that has no problems whatever.

Does anyone recall any problems with ext2 in 2.0 or am I looking at some
subtle disk problem that is not being detected by the IDE driver (the
latter is my current hypothesis).

--------------------------------------------------------------------------
Grant R. Guenther grant@torque.net
--------------------------------------------------------------------------

\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.147 / U:0.756 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site