lkml.org 
[lkml]   [1996]   [Aug]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: more NCR53c8xx ext2 problems.
On Wed, 21 Aug 1996, Gerard Roudier wrote:

> - 2 bits memory error
> - broken CPU
> - bad scsi cables
> With memory errors or a broken CPU, you should have lots of other problems
> with your system. If the scsi cables were bads, then you should get scsi
> transfer errors, and/or scsi parity errors.

I've been suspecing my cables only because I know they are run of the
mill SCSI cables, and not the platinum wire ones I have on the shelf
waiting to get installed. I don't think I've ever seen a parity error
logged though. I have more than 8 months of compressed kernel message logs
archived...and am now doing a:
zgrep ext2 * | grep -v Mounted | cut -d : -f5- | sort | uniq | less

in my news server's kernel message log archive dir

EXT2-fs error (device 08:21): ext2_add_entry: bad entry in directory
#1231295: rec_len is too small for name_len - offset=5632, inode=1235180,
rec_len=16, name_len=1541
EXT2-fs error (device 08:21): ext2_find_entry: bad entry in directory
#1231295: rec_len is too small for name_len - offset=5632, inode=1235180,
rec_len=16, name_len=1541
EXT2-fs error (device 08:21): ext2_find_entry: bad entry in directory
#1231312: rec_len != 0 - offset=1584, inode=2668876414, rec_len=65511,
name_len=65533
EXT2-fs error (device 8/33): ext2_add_entry: bad directory entry:
rec_len != 0
EXT2-fs error (device 8/33): ext2_add_entry: bad directory entry:
rec_len is too small for name_len
EXT2-fs error (device 8/33): ext2_find_entry: bad directory entry:
rec_len != 0
EXT2-fs error (device 8/33): ext2_find_entry: bad directory entry:
rec_len is smaller than minimal
EXT2-fs error (device 8/33): ext2_find_entry: bad directory entry:
rec_len is too small for name_len
EXT2-fs error (device 8/33): ext2_readdir: bad directory entry: rec_len
is toosmall for name_len

If device 08:21 is just another way of saying device 8/33, then that
would point fingers at my problem being on
brw-rw---- 1 root disk 8, 33 Apr 29 1995 /dev/sdc1
/dev/sdc1 2399101 1095924 1283177 46% /var/spool/news/alt

This is part of a Micropolis 3243. I've had bad feelings about this drive
for some time. We had major trouble with 3243's eating thier bearings
about a year ago. I've run the thing async with rel11+ and earlier, sync
with rel11+, sync with the BSD ported driver. Always, I've gotten errors
anywhere from multiple fsck's a day to every few weeks.

BTW...it's not a cooling problem. The 3243 has muffin fans just in front
of and behind it (hard drive wind tunnel) pushing air towards the back of
the case, where more fans exhaust it.

> If you only get ext2 directory errors, it might be a software problem.

I seem to only get these directory errors...but only on one partition of one
disk on a 4 disk box with 2 NCR boards (sda and sdb on one, sdc and sdd
on the other).

------------------------------------------------------------------
Jon Lewis <jlewis@fdt.net> | Unsolicited commercial e-mail will
Network Administrator | be proof-read for $199/hr.
________Finger jlewis@inorganic5.fdt.net for PGP public key_______


\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.081 / U:3.536 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site