lkml.org 
[lkml]   [1996]   [Jul]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subjectfile-system changes? fork probs? old app "plany" no longer works.
Date
I feel as though I'm a voice crying out in the wilderness, since
no one else seems to running this little utility. But here goes
anyway:

Since linux kernel version 1.1.x, I've been using this shoddy,
but useful little utility called plany: it's a front-end menu
database for sound players (in my case: vplay for WAVs and VOCs,
cat to /dev/audio for .au's, nspmod and mikmod for MOD's and their
kin, and playmidi for MIDI files). It's has an ncurses interface.
It has the neat feature that it look inside .ZIP, .LHA, and any
other type of archive for sound files -- and it will automatically
extract and play them.

Well, it's worked without trouble up through version 2.0.0 --
in kernels 2.0.1 through 2.0.4 it breaks.

Where the problem is -NOT- : it's not with zip or unzip, they
both still work fine. The problem also does not lie with the
players, although the new USSlite has and continues to have
problems with SB16 MIDI daughterboards. I've thouroughly
checked all this.

Plany takes 3 types of arguments: it can take files, which it
unzip/extracts and show you the contents and lets you select
and play the sounds. It can take directory names, in which case
it looks for sounds files, and adds them to it's database,
recursing directories and scanning in archives. It also takes
the parameter "-d", where it just uses the existing database.

Apparenly plany spawns the players as seperate processes -- it
allows you to scroll around and tag other files in the database,
while it's playing. It'll also kill off currently running players
when you choose another file to play.

Now on my system, all my sound files are on an msdos-filesystem.
In all the kernels I've used from 1.1.x to 2.0.0 -- it'll read
from the directories just fine. But in 2.0.1 and later it freezes
while reading directories. (it doesn't lock up the system, you
can ctrl-c out of it). It also no longer saves it's database.

I also tried moving my modules and sounds onto my ext2 partition.
In this case plany will read directories -- but for some reason
it refuses to play files that have uppercase names. And it still
doesn't save it's database.

(note: the ZIP format allows long and case-sensitive file names.
plany extracts to /tmp on my ext2 partition -- I've tried amending
plany's .cfg file with unzip's -C and -L options to no avail)

I'm not throwing a fit over this -- if the kernel has changed
for the better, I can live without plany -- or find another app,
or even try to fix it to make it work again.

...but I'm curious as to why this has happened. What has changed
between 2.0.0 (and previous) where it works flawlessly, and 2.0.1
(and later) where it seems to be broken in multiple places. I
looked at the non-USSlite parts of the 2.0.1 patch, but I didn't
find any clues. I mean, is this a symptom of some deeper problem???

System info: Currently running linux 2.0.0 ; P5-100 16Mb ;
ELF ; libc 5.4.2 ; ld.so 1.8.1 ; SB16SCSI-2 w/ WaveBlaster.
Haven't made any other changes to the system since pre-2.0, that
might explain this odditystart.

I do load the sound driver (as well as most others) as a module
with kerneld -- but I've got this well configured; and it's never
given me any problems before. using modules-2.0.0.

I've tried all kernels 2.0.x -- returning to 2.0.0 restores it to
proper function.

Plany v0.1 is available at:
ftp://sunsite.unc.edu/pub/Linux/apps/sound/players/plany.tar.gz
for those that want to check it out.

---
Mark Orr
markorr@intersurf.com


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.177 / U:0.516 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site