lkml.org 
[lkml]   [1996]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ATAPI CDROM kernel problems
On Sat, 6 Jul 1996, Andrew E. Mileski wrote:

> > > Is the info in the IDE documentation about the tertiary port any help?
> >
> > Not particularly. I've tried using the kernel boot parameters it mentions,
> > but the kernel seems *convinced* that the IDE port is in use.
> >
> > LILO boot: Linux ide2=0x1e8,11 hde=cdrom
> ^^ I think this is wrong.
> Docs say you can leave out the IRQ number, but you need the port number.

By that point I was desperate. :)

> Shouldn't that be 'ide3=0x1e8,0x03ee,11' for the tertiary (third) controller?

I think ide3 is quartenary(sp). ide0 is primary, ide1 is secondary, ide2
tertiary, and ide3 is the fourth.

I got it working this morning, though. Basically, I changed the card
settings to some odd ones (odd according to the PnP Manager, not that I
trust it), and it booted fine. Someone mailed me and told me to look at
/proc/ioports -- I wish I'd known about that one sooner. Seems that Linux
allocates those addresses for a serial driver.

Oops. :) So the problem wasn't the kernel, but my ignorance of the
diagnostic capabilities of the /proc filesystem. :)

I thank everyone for all the help.

Regards.



\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.036 / U:1.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site