[lkml]   [1996]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subject2.0.4 -- boot from ramdisk broken??
I am having some trouble with booting from a ramdisk.  At this
point, I have tried using kernels with/without initrd support, but nothing
seems to work. The kernel boots and detects all of the hardware
properly, but right after it mounts the root filesystem on the ramdisk,
the system just stops -- no error messages, nothing from init, etc.

I have read all of the documentation I can get my hands on, and
I have followed the examples to the letter and I still get the same
result every time. My setup is as follows:

floppy #1: kernel 2.0.4, lilo 19
floppy #2: compressed ramdisk image copy of the redhat rescue
diskette. Compressed image starts at block 0,
and it was compressed with gzip -v9 .

# Start LILO global section
boot = /dev/fd0
vga = -1 # force sane state

# Linux bootable partition config begins
image = /zImage
root = /dev/fd0H1440
#load ramdisk from floppy
#ask the user to insert a floppy
#specify the size of the ramdisk
append="load_ramdisk=1 prompt_ramdisk=1 ramdisk_size=2880 ramdisk_start=0"
label = linux

I don't have the .config right here in front of me, but I would be happy to
get it and send it to anyone who's interested. If the problem is something I
messed up, I would be happy to hear it, since we need this to do backups of
our systems.


FAQ Suggestions:
Q: I upgraded without reading release notes, now my system's broke - why?
A: What the @!#* did you expect?
(this assumes that someone reads the faq, of course ;)

 \ /
  Last update: 2005-03-22 13:38    [W:0.031 / U:7.436 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site