lkml.org 
[lkml]   [1996]   [Jun]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectTCP tunnel and forwarder broken since pre 1.99.10
Date

Hi, I'm using a somewhat strange setup, which I first configured with
1.99.9, where it worked perfectly. The setup is this.


The network 194.224.147.64 netmask 255.255.255.252 (I only have two machines
at home .65 and .66 .65 has the modem), is officialy gatewayed by the machine
194.224.147.2

In 194.224.147.2 the network is IP tunneled to my ppp dialin address. On
my dial in machine I have a tunnel to 194.224.147.3 routed through my modem
and my default route is set to 194.224.147.3 via the tunnel.

In 1.99.9 this all worked fine. Since 1.99.10 THe gateway machine still works
fine, but the second machine can only transfer so much before a connection
hangs. This is 100% repeatable. If I telnet to my news server, type list
the output always stops at the same place (after transfering 36227bytes).

Once a connection has stopped, it appears that both ends just loose interest,
netstat shows both ends in the established state with nothing in the send/recv
queues on either end. The last bytes to pass the ppp link according to tcpdump
were:

02:29:06.682247 0.0.192.202 > 36.97.8.0: ip-proto-196 500
02:29:06.682247 0.0.192.202 > 36.97.8.0: ip-proto-196 500
02:29:07.082247 pi.sitrantor.es.1068 > trantor.sitrantor.es.nntp: . ack 36418
win 31744 (encap)
02:29:07.502247 0.0.192.202 > 36.97.8.0: ip-proto-196 500
02:29:07.502247 0.0.192.202 > 36.97.8.0: ip-proto-196 500
02:29:07.902247 pi.sitrantor.es.1068 > trantor.sitrantor.es.nntp: . ack 36878
win 31744 (encap)


The problem seems to be only in the gateway machine. With 1.99.9 running in
that machine the setup works, with 1.99.10 it is stops. 1.99.10 changed several
things related to acks and such, it would appear one of these breaks IP
tunnels. As this is 100% reproducable and I can tcpdump any part of
the chain, I would like advice on finding out why it broke.

--
Jon. <jon@gte.esi.us.es, http://www.esi.us.es/~jon>


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.043 / U:0.352 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site