lkml.org 
[lkml]   [1996]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectpre-2.0.13: is this an IP bug?
Hello All,

I just booted into pre-2.0.13 and noticed these messages occured
after about an hour or so of uptime. Did I hear (from Alan??) that the
ip_queue_xmit message is cosmetic? But what about the BUG message? (any
message which explicitly has the word BUG in it gives me the heebee
jeebies). =]

Jun 6 11:43:16 earth kernel: ip_queue_xmit: frag needed
Jun 6 11:43:23 earth last message repeated 5 times
Jun 6 11:43:23 earth kernel: IP fragmenter: BUG free!=1 in fragmenter
Jun 6 11:43:23 earth kernel: IP fragmenter: BUG free!=1 in fragmenter
Jun 6 11:43:42 earth kernel: ip_queue_xmit: frag needed
Jun 6 11:43:59 earth last message repeated 4 times


I'm using pppd-2.2.0f for my outside link and an NE2000 for my localnet.
Everything is a module. I have enabled the options for ALWAYS DEFRAGMENT,
IP FIREWALLING, IP MASQUERADING and IP FORWARDING. My ppp interface has
an MTU of 1500 (doing some testing) up from 596 which it always was before
today. I have two IP masqueraded machines behind mine; one on thinnet and
one on plip. Thanks for any response,

-Bryan
--
# B. James Phillippe # System Administrator [terran.org]
# <bryan@terran.org> ~ http://www.terran.org/~bryan



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.026 / U:4.924 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site