lkml.org 
[lkml]   [1996]   [Jun]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Alan's bug catalogue/SCSI hangups
scldad@sdc.com.au writes: 
>
> This problem seems to be somewhat specific in its appearance.
>
> I now have all of the relevant SCSI code built into my 1.99.10 kernel
> (and have had for the past few releases) but still get a hung system
> whenever I try to tar from a SCSI disk to a SCSI tape (Exabyte).

Are you running a fast (> 100Mhz) Pentium system?

I am having a similar problem ... mine, however occurs when backing-up an
IDE disk to a SCSI tape. The result is usually "silent system death", no
error messages.

It is a very curious problem and only seems to occur with our 120Mhz
Pentium systems.

We have been running Linux for over 3 years now on a variety of machines
(486-33 to Pentium 120) and have always used a SCSI tape drive (QIC or
Exabyte) attached to an Adaptec 1542C to backup-up our IDE disks. Until
recently we have had *no* problems with this set-up. The problems began
when I upgraded our Pentium 60s to 120s ... the first time I tried to
back-up my machine it locked-up solid. I first suspected my Exabyte
drive but the same result occured with a second Exabyte drive, a DAT
drive and a QIC drive. My next suspect was the motherboard ... two
different motherboards gave the same result. Looks like it's our
venerable 1542C ... well I just received a BusLogic 948T and it locked
up during last nights backup. Results are a bit different with the
BusLogic in that *sometimes* the backup will complete successfully.

Note that through all of this, the 486 systems have worked flawlessly.
All systems except one are running 1.3.76, the exception is my system
on which I am currently running 1.99.5. These are working systems so
I cannot afford to do much more experimenting ... if I get the chance
I will try reverting to 1.2.13.

>
> I am only guessing, but Alan's suggestion of timing/interrupt problems
> sounds good to me.

This sounds plausible to me as well.

--
Mike

-----------------------------------------------------------------------------
Mike Kenney
UW Applied Physics Lab
mikek@apl.washington.edu (206) 543-1300 / (206) 543-6785 FAX
-----------------------------------------------------------------------------


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.053 / U:10.888 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site