lkml.org 
[lkml]   [1996]   [Jun]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectNo Distribution is 2.0.0 Current
In my opinion no Distribution is Linux 2.0.0 current.
To me to be 2.0.0 current all free packages must be compiled
against the Linux 2.0.0 source tree, with the same libc or later than
the developers use. It must also include the kernel support utilities
that have been patched to work with 2.0.0 and all support tools need
to be updated to support all the standard features of 2.0.0.

Some have responded to my challenge of RedHat where I complained about
some nits. I really wasn't expecting RedHat to meet my currency
requirement it is to strict for a June Release. My opinion is that no
distribution should claim to be 2.0.0 current until the iterative
process of fix test refix progressively up the chain of applications
has a chance to occur. I think the earliest resonable release would be
in August. I think those of us on this channel who encourage any
other belief are doing ourselves a disfavor as we are asking to be
bombarded with questions of why doesn't this work.

To all those who suggested Debian 1.1, It may not require replacement
packages to work (I don't know how well) with 2.0.0 but it definately
doesn't meet my definition of current. Some of the packages I checked
were even older than the RedHat comparables. For example Modutils and
PCMCIA.

I personally would like to know what versions of Libc, ppp, Modutils,
PCMCIA, sound ... the developers of those packages would consider the
correct release to go with Linux 2.0.0, and so on up the application
tree. I assume those developers moniter this channel since the kernel
is the root of all evil. This is a more strigent definition than the
requirements for the compilation of the kernel. It is however, I
believe the correct criteria for a distribution current with Linux 2.0.0
and it may even require patching 2.0.0 to make it Happen.

Please do not call any distribution Current yet. Yes some can support
the compilation of 2.0.0. But I know all of them require upgrading to
be current with the system I currently run. Libc-5.3.12 for example.

Hubert Bahr,


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.038 / U:0.196 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site