[lkml]   [1996]   [Jun]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectProblem with sound driver in 2.0.0
Chris Adams writes:
> I am trying to use the sound driver in 2.0.0 with a ProAudio Spectrum 16
> sound card, and it doesn't work. All I get is:
> Sound: DMA (output) timed out - IRQ/DRQ config error?
> I have tried every combination of IRQ/DMA setting I can think of, and I
> still get the above message. I think it used to work with older kernels
> (I haven't used the sound card in a while), and it works fine under
> MS-DOS (I tried the settings I use under DOS first).
> I have a Intel Triton motherboard with a Pentium 100. I don't have an
> Adaptec 1542 (the HOWTOs and READMEs say there are problems with these).
> the only other card in the computer (other than video) is a Linksys
> NE2000 compatible ethernet card. I have tried with the PAS16 SCSI
> configured and without, and with and without the NE2000 driver. This is
> all on a RedHat 3.0.3 system upgraded using the packages at RedHat's
> site.

I get similar messages with my Gravis Ultrasound, but intermittently. I
have only been able to get them to happen while playing DOOM; normal
/dev/audio use doesn't seem to trigger it, although something possibly
related causes very infrequent and intermittent failures of programs
that use /dev/audio. However, in those cases the "DMA (output) timed
out" message doesn't appear; the program just says it failed to open
/dev/audio that time.

I know there aren't any IRQ or DRQ conflicts on my system, and I have a
busmastering SCSI controller that uses DMA and doesn't exhibit problems
of this sort. I also believe there was a time when the sound driver
didn't exhibit this problem, but sadly I can't remember exactly when I
saw the problem start.

 \ /
  Last update: 2005-03-22 13:37    [W:0.059 / U:21.508 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site