lkml.org 
[lkml]   [1996]   [Jun]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Mysterious hang in 2.0.0 - possibly Triton II?
Hi folks,
Bad news for me! - I took out the Triton support in my 2.0.0
kernel and it no longer hangs.

Linux pnd-pc 2.0.0 #16 Fri Jun 14 21:38:41 BST 1996 i586
8:33pm up 5 days, 2:43, 3 users, load average: 0.00, 0.03, 0.02

Now, I'm not giving up on Triton support per se, as it could be other
things, and other people report that they are using Triton II machines
with no problems.

I've included most of the following reply as it wasn't sent to the list -
sorry for the long message.

On Sat, 15 Jun 1996, James Jones wrote:

> I've been following this for a while because I started getting lock ups
> around 1.9.12 and they have just stopped with 2.0.0 (uptime 5.5 days now
> - it was about 1 day). I didn't have the capabilities of doing extensive
> testing because it would take a long time before it would lock.
>
> I first noticed the locks after recompiling the kernel to support a
> Buslogic SCSI controller and a PCI ethernet card (not the lance). Didn't
> have them, but I wanted to re-try my Buslogic which has never worked
> right - and still doesn't.
>
> Anyway, of course, I thought that was the reason, but taking them out
> didn't fix them.
>
> I have Triton II chipset, APM disabled and support not compiled, 2 SCSIs
> and 2 IDE hard drives. 1 lance PCI ethernet and 1 NE2000 clone.
>
> I attacked the problem from a software point of view since there wasn't
> anything I could do about the hardware at that time. I was running the
> latest everything listed in the Changes file as far as libs and stuff go.
>
> I recompiled sendmail with FLOCK / without FLOCK - still locked either way.
>
> Nothing I changed or seemed to make any difference until:
>
> I upgraded from 1.9.14 to 2.0.0 kernel
> I downgraded from libc-5.3.12 to libc-5.2.18
> I recompiled procmail to use FLOCK instead of FCNTL
> I set my news to expire twice daily instead of once a day
> (I have a small newsfeed - keep only about 2300 groups
> for 3-7 days).
>
> I took everthing I can think of and changed it to use FLOCK. I tried to
> recompile qi to not do locking on reading, but it didn't run after
> compiling, so I just went back to the old version (it was getting early
> in the morning and I needed sleep).
>
> Since I made several changes at once, I can't tell you which it is, and
> I'm still waiting for it to crash - but like I said - it's been 5.5 days
> now and it's still going.
>
So it could be FLOCK problems, or it could still be hardware -
either the NE2K clone, or an actual buggy chipset. I don't think it's
thermal. Someone else suggested EIDE cable lengths, and I have yet to
check this.

I'll keep everyone posted, unless I'm told not to :-)

Cheers,
Peter

--
Peter Denison <peterd@pnd-pc.demon.co.uk>
Currently (still) working on a driver for Promise cards under Linux.



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.018 / U:2.736 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site