lkml.org 
[lkml]   [1996]   [Jun]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: unprecise report: lockups when using loopback
In article <199606192002.WAA18322@rymunda.torun.pdi.net>,
Rafal Maszkowski <rzm@torun.pdi.net> writes:
> It won't be a precise report but I couln't spend more time on finding
> what exactly is wrong.
>
> I tried to use yard-1.4 (tool for creating safety floppies - it
> (1) mounts a filesystem, populates it with most important binaries,
> (2) checks it, (3) compresses and writes kernel and compressed fs to
> one floppy) with loopback (instead of normal RAM disk). It locked
> up my machine few times. I got two more less immediate lockups in
> 3rd stage (write_rescue_disk.pl). Recently also in the firts stage
> (creat_root_fs.pl) - it stopped while writing, my ls on the mounted
> loopback fs was stopped in 'D' state; the system was running normally
> for some time and then, after few minutes it locked, i.e. I could only
> switch consoles, nothing else. I'm suspecting that even just writing
> to loopback mounted fs is causing these strange efects.

I also encountered some strange problems with the loop device. I played
with an encrypted loopback mount, but on several occasions I got a
corrupted file system, eventually leading to a system crash. For
instance, I got pieces of C source code in an object file and files with
invalid modes. It has nothing to do with the encryption, because it also
occurs with a plain loopback mount. I tried very hard to get a
reproducible scenario showing the problem, but failed until now.
Therefor, I thing there is some race condition in the kernel concerning
the loopback device. I will continue to investigate the problem, but if
anyone has suggestions, please come forward.

--
Dick Streefland //// Tasking Software BV
dicks@tasking.nl (@ @) The Netherlands
------------------------oOO--(_)--OOo------------------------


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.036 / U:0.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site