lkml.org 
[lkml]   [1996]   [Jun]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 2.0.0 fails to return Text File Busy for .so files
Paul Wouters <paul@xtdnet.nl> wrote:
>But to get back on the procedure. Isn't it a lot easier then you describe?
>If you have /lib/libfoo.so.x.1.2.3 and you want to upgrade to version
>1.2.4, you can just move it into the same directory and run ldconfig. It
>will change the link for you to the newer version. No nasty and dangerous
>moving of files needed. If you're still paranoid, you can reboot just to
>make sure :)
Having upgraded to 2.0.0 from a Slackware 3.0 system I also installed the
new libc.so.5.3.12 in /lib and ran ldconfig. No change from the previous
5.0.9? I then tried libc.so.5.2.18 instead and that worked when running
ldconfig. Is there anything special to do when upgrading to libc.so.5.3.12?
I can't find that there should be, anywhere in the documentation?

>
>Paul (Who almost did a make install on the new libc while compiling a new
> kernel and decided it wasn't worth the risk ;)
Chicken! ;-)

Peter


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.028 / U:6.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site