lkml.org 
[lkml]   [1996]   [Jun]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectPProbablem with 'make'
Date



I'm not sure if this is a probablem with upgraading my kernel or what
but my make program no longer seems to work. Right after I upgraded it
worked fine for installing procpss. But now it doesn't seem able to
find the 'Makefile' by default, but sit finds 'makefile' and 'GNUmakefile'
fine. If I use the -f option with it to specify the Makefile it's ubable
to compile the files right because something like:

all: file1.o file2.o

Will give an error:

make: *No rule to make 'file1.o' required for so and so*

I read the release notes with the libc upgrade and it says make might be
broke with the new dirent structure. I even tried recompiled make (Which I
mainly had to do by hand) but I still got the same errors from the new binary.

I checked the permissions on the directories and the files where I was
compiling and they are all correct. The 'x' flag is on the directories
for searching them and root does own them which I'mm currently compiling
with. They are also readable and writable by owner, group, and user so
that shouldn't be a probablem either.

Right now I have absolutetly no idea what the probablem could be. And
I really need to get the probablem fixed so I can compiled a bunch
of programs I need to compile. If anyone has got similar probablems and
has fixed them please let me know how you fixed them.

- Jim


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.024 / U:13.644 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site