lkml.org 
[lkml]   [1996]   [Jun]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectSerial Module Probablem
Date

I compiled serial handling as a module and have kerneld running to
automatically load it when it's needed. Noww the probablem comes when
I try to run minicom. The first time I run minicom It gives a /dev/cua3
no such file error and doesn't start up.

I checked /proc/modules and serial is loaded with autoclean on. I try
to run minicom a second time and it boots up fine because serial is already
loaded. Anyone know if this is a probablem with kerneld, or minicom, and if
it is minicom would an upgrade fix it?

As a couple of side notes:

Anyone know why mcd would work but mcdx wouldn't in this
setup. I have a old single speed Mitsumi CD-ROm, it's located at address
0x300, IRQ 11. Now if I use the 'mcd' mounting and cd playing works fine.
But if I try to use mcdx and then try to mount I get an unable to
load superblock or something similar. And if I try to run workbone the
error is just I/O error. The 'Busy' light does come on for a sec in both
cases.

Another probablem I'm having is in compiling dosemu. I got the newest
version of dosemu. Now I got it to compile fine up until the linking process.
In the linking processe iit seems unable to load any of the functions
from the libslang libraries because I get a bunch of undefine function errors.
I've tried both libslang elf and a.out format.ss. It should be using the
elf format tho since I have an elf compiler. I've also successfully compiled
the new version of procps for 2.0 with this linker so I kind of doubtful
it's ld which I have version cygnus-2.6 (with BFD 2.6.0.14). gcc is version
2.7.0 ELF compiled in as the default.

I have know idea where the cause of these probablems come from so I have no
idea where to start looking so any help would be very much appreciated.

- Jim


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.029 / U:8.668 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site