lkml.org 
[lkml]   [1996]   [Jun]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectCan't Compile floppy.c.
-- 
_____________________________________________________________________

Edwin Culp mailto:eculp@mexcom.net
HTTP://WWW.MEXCOM.NET

MEXICO COMMUNICATES, S.C.
World Trade Center Edificio Florida
Blvd. Adolfo Ruíz Cortines No. 3497 Av. Insurgentes S. 1677-1005
Salón "OLMECA" Col. Guadalupe Inn
94290 Boca del Río, Ver. 01020 Mexico, D.F.
(29) 21-3949 (5) 662-7132 / 663-2581
_____________________________________________________________________
I am compiling v2.0.0 and have the following problem with floppy.c.
Here I am compiling as a module, but I get the same error if I try to include
it in the kernel.

gcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strength-reduce -pipe -m486 -DCPU=486 -DMODULE -DMODVERSIONS -include /usr/src/linux/include/linux/modversions.h -c -o floppy.o floppy.c
cpp: output pipe has been closed
gcc: Internal compiler error: program cc1 got fatal signal 11
make[2]: *** [floppy.o] Error 1
make[2]: Leaving directory `/usr/src/linux/drivers/block'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux/drivers'
make: *** [modules] Error 2

My versions of everything that I can think of are:
gcc version 2.7.2p
/lib/libc.so.5 -> libc.so.5.3.12
/usr/lib/libg++.so -> libg++.so.27.1.4
ld version cygnus-2.6 (with BFD 2.6.0.12)
ldd: version 1.7.14
/lib/libtermcap.so.2 -> libtermcap.so.2.0.8
modules Version 2.0.0
procps version 0.99

I have had this problem since 1.3.9x, more are less.
I must be behind on something because the < 1.3.9x work
fine. Thank you for your help and patience.

Ed Culp

P.S. I will be happy to RTFM just help me find the right one.
\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.024 / U:2.948 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site