lkml.org 
[lkml]   [1996]   [May]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: .98 lp.o not working, .97 OK
> lp.o just says "kernel: lp1 off-line" repeatedly. It does print something
> after a while (a page every few minutes) but it is useless.
>
> I tested again with .97 and it works OK.
>
> I load lp.o as a module, if it matters.
>
> BTW, lp.o is used in it's default (polling) mode. I never got it to work
> with interrupts (I tried to set "io=0,0x378,0 irq=0,7,0" and the startup
> message said "(irq = 7)" but I never saw one character printed. I did not
> yet search enough on this matter neither did I play with tunelp yet.

same here. it is printing a line in every tenth second or so.

now i tried tunelp -i 7
and printing works again

so, there is something with the polling mode.

--
Matics Gyula
mgyula@sch.bme.hu Linux!



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.070 / U:22.836 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site