lkml.org 
[lkml]   [1996]   [May]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: is 1.3.98 makefile broken?
On Sat, 4 May 1996, valhalla wrote:

> I just downloaded the 1.3.98 patch , patch -p0 'ed it ... and tried to
> make it
> this is what I got:
>
> swamp:/usr/src/linux#make config
> make: *** No rule to make target `config'. Stop.
> swamp:/usr/src/linux#
>
> anyone else have this problem?
> -Joe

Did you also happen to upgrade libc recently? I believe that there was a
hole in one of the dirent functions or something that GNU make, among
other programs, exploited and the versions of libc that have the hole
fixed break those programs.

There's a patch file for GNU make that comes with the release notes for
libc that fixes the error - just d/l the make sources from your local GNU
mirror, apply the patch, and compile a new "make" that'll work.

Hope this helps :)

(the patch-1.3.98 worked fine for me, so it's not a broken Makefile..)

-- Matt

-,-,-,- Cogito Eggo Sum - "I think, therefore I am a waffle" -,-,-,-,-,-,-,-,-,-
Matthew Hawkins - part-time programmer, sysadmin, BOFH. Full-time Geek.
matt@blitzen.canberra.edu.au President, UC Computer Club. (UCNET)
-'-'-'-'-'-'-'-'-'-'- Veni, Vidi, Vice - "I came, I saw, I partied" '-'-'-'-'-'-




\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.038 / U:0.876 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site