lkml.org 
[lkml]   [1996]   [May]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject1.3.98 module compile errors
Date

The sound module didn't compile for me and some modules don't get inserted.
I am not going to try to be a kernel hacker, so here the warnings and
errors I got.

Here are some warnings with MODVERSIONS enabled when doing a make dep :
(I am using modules-1.3.69f)

make[1]: Entering directory `/usr/src/linux/kernel'
genksyms "ksyms.c": warning: symbol [do_mmap]: unknown 'struct sock'
make[1]: Leaving directory `/usr/src/linux/kernel'
make[2]: Entering directory `/usr/src/linux/drivers/char'
genksyms "misc.c": warning: symbol [misc_register]: unknown 'struct sock'
make[2]: Leaving directory `/usr/src/linux/drivers/char'
make[2]: Entering directory `/usr/src/linux/drivers/scsi'
genksyms "scsi_syms.c": warning: symbol [scsi_register]: unknown 'struct sock'
make[2]: Leaving directory `/usr/src/linux/drivers/scsi'
make[2]: Entering directory `/usr/src/linux/fs/fat'
genksyms "fatfs_syms.c": warning: symbol [fat_add_cluster]: unknown 'struct sock'
make[2]: Leaving directory `/usr/src/linux/fs/fat'
make[2]: Entering directory `/usr/src/linux/fs/msdos'
genksyms "msdosfs_syms.c": warning: symbol [msdos_create]: unknown 'struct sock'make[2]: Leaving directory `/usr/src/linux/fs/msdos'
make[2]: Entering directory `/usr/src/linux/fs/proc'
genksyms "procfs_syms.c": warning: symbol [proc_register]: unknown 'struct sock'make[2]: Leaving directory `/usr/src/linux/fs/proc'
make[1]: Entering directory `/usr/src/linux/net'
genksyms "netsyms.c": warning: symbol [sock_register]: unknown 'struct ncp_server'
make[2]: Entering directory `/usr/src/linux/net/802'
genksyms "p8022.c": warning: symbol [register_8022_client]: unknown 'struct sock'
genksyms "p8022.c": warning: symbol [register_8022_client]: unknown 'struct ip_mc_list'
genksyms "p8022.c": warning: symbol [register_8022_client]: unknown 'struct net_alias_info'
genksyms "p8022.c": warning: symbol [register_8022_client]: unknown 'struct net_alias'
genksyms "p8022.c": warning: symbol [register_8022_client]: unknown 'struct tcphdr'
genksyms "p8022.c": warning: symbol [register_8022_client]: unknown 'struct iphdr'
genksyms "p8022.c": warning: symbol [register_8022_client]: unknown 'struct udphdr'
genksyms "psnap.c": warning: symbol [register_snap_client]: unknown 'struct sock'
genksyms "psnap.c": warning: symbol [register_snap_client]: unknown 'struct ip_mc_list'
genksyms "psnap.c": warning: symbol [register_snap_client]: unknown 'struct net_alias_info'
genksyms "psnap.c": warning: symbol [register_snap_client]: unknown 'struct net_alias'
genksyms "psnap.c": warning: symbol [register_snap_client]: unknown 'struct tcphdr'
genksyms "psnap.c": warning: symbol [register_snap_client]: unknown 'struct iphdr'
genksyms "psnap.c": warning: symbol [register_snap_client]: unknown 'struct udphdr'
genksyms "p8022tr.c": warning: symbol [register_8022tr_client]: unknown 'struct
sock'
genksyms "p8022tr.c": warning: symbol [register_8022tr_client]: unknown 'struct
ip_mc_list'
genksyms "p8022tr.c": warning: symbol [register_8022tr_client]: unknown 'struct
net_alias_info'
genksyms "p8022tr.c": warning: symbol [register_8022tr_client]: unknown 'struct
net_alias'
genksyms "p8022tr.c": warning: symbol [register_8022tr_client]: unknown 'struct
tcphdr'
genksyms "p8022tr.c": warning: symbol [register_8022tr_client]: unknown 'struct
iphdr'
genksyms "p8022tr.c": warning: symbol [register_8022tr_client]: unknown 'struct
udphdr'
make[2]: Leaving directory `/usr/src/linux/net/802'

After that, I disabled MODVERSIONS to stay away from those warnings.

make dep produced no warnings/errors
make zImage produced unused variable warnings
make modules produced these errors:

make[2]: Entering directory `/usr/src/linux/drivers/scsi'
ppa.c:498: warning: initialization from incompatible pointer type
aha152x.c:2981: warning: initialization from incompatible pointer type
aha1740.c:521: warning: initialization from incompatible pointer type
make[2]: Leaving directory `/usr/src/linux/drivers/scsi'
make[2]: Entering directory `/usr/src/linux/drivers/sound'
sb_dsp.c: In function `ess_init':
sb_dsp.c:1328: warning: implicit declaration of function `ess_write'
sb_dsp.c: In function `sb_dsp_init':
sb_dsp.c:1533: `sbintr' undeclared (first use this function)
sb_dsp.c:1533: (Each undeclared identifier is reported only once
sb_dsp.c:1533: for each function it appears in.)
sb_dsp.c:1481: warning: unused variable `mixer_type'
sb_dsp.c: At top level:
sb_dsp.c:50: warning: `open_mode' defined but not used
sb_dsp.c:55: warning: `dsp_count' defined but not used
sb_dsp.c:56: warning: `trigger_bits' defined but not used
sb_dsp.c:76: warning: `dsp_stereo' defined but not used
sb_dsp.c:77: warning: `dsp_current_speed' defined but not used
sb_dsp.c:78: warning: `dsp_requested_speed' defined but not used
sb_dsp.c:80: warning: `irq_verified' defined but not used
sb_dsp.c:87: warning: `irq_ok' defined but not used
sb_dsp.c:90: warning: `dsp_16bit' defined but not used
sb_dsp.c:97: warning: `dsp_set_bits' declared `static' but never defined
sb_dsp.c:104: warning: `my_dev' defined but not used
sb_dsp.c:108: warning: `dsp_speed' declared `static' but never defined
sb_dsp.c:109: warning: `dsp_set_stereo' declared `static' but never defined
sb_dsp.c:110: warning: `sb_dsp_reset' declared `static' but never defined
sb_dsp.c:1287: warning: `ess_init' defined but not used
make[2]: *** [sb_dsp.o] Error 1
make[2]: Leaving directory `/usr/src/linux/drivers/sound'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux/drivers'
make: *** [modules] Error 2

Most of the modules that did compile did work expect these three.

insmod scsi/sd_mod.o

resetup_one_dev undefined
gendisk_head undefined
Loading failed! The module symbols (from linux-1.3.98) don't match your linux-1.3.98

insmod net/ppp.o

slhc_free undefined
slhc_init undefined
slhc_toss undefined
slhc_uncompress undefined
slhc_remember undefined
slhc_compress undefined
Loading failed! The module symbols (from linux-1.3.98) don't match your linux-1.3.98

insmod net/bsd_comp.o

ppp_register_compressor undefined
ppp_unregister_compressor undefined
Loading failed! The module symbols (from linux-1.3.98) don't match your linux-1.3.98

Ok. Here is my .config:
#
# Code maturity level options
#
CONFIG_EXPERIMENTAL=y

#
# Loadable module support
#
CONFIG_MODULES=y
# CONFIG_MODVERSIONS is not set
CONFIG_KERNELD=y

#
# General setup
#
# CONFIG_MATH_EMULATION is not set
CONFIG_NET=y
# CONFIG_MAX_16M is not set
# CONFIG_PCI is not set
CONFIG_SYSVIPC=y
CONFIG_BINFMT_AOUT=y
CONFIG_BINFMT_ELF=y
CONFIG_KERNEL_ELF=y
CONFIG_M486=y

#
# Floppy, IDE, and other block devices
#
CONFIG_BLK_DEV_FD=y
CONFIG_BLK_DEV_IDE=y
# CONFIG_BLK_DEV_HD_IDE is not set
# CONFIG_BLK_DEV_IDECD is not set
# CONFIG_BLK_DEV_IDETAPE is not set
CONFIG_BLK_DEV_IDE_PCMCIA=y
CONFIG_BLK_DEV_CMD640=y
# CONFIG_IDE_CHIPSETS is not set
CONFIG_BLK_DEV_RAM=m
CONFIG_BLK_DEV_LOOP=m
# CONFIG_BLK_DEV_XD is not set
# CONFIG_BLK_DEV_MD is not set

#
# Networking options
#
# CONFIG_FIREWALL is not set
CONFIG_NET_ALIAS=y
CONFIG_INET=y
CONFIG_IP_FORWARD=y
CONFIG_IP_MULTICAST=y
CONFIG_IP_ACCT=y
# CONFIG_IP_ROUTER is not set
CONFIG_NET_IPIP=m
# CONFIG_IP_MROUTE is not set
CONFIG_IP_ALIAS=m
# CONFIG_ARPD is not set
# CONFIG_INET_PCTCP is not set
# CONFIG_INET_RARP is not set
# CONFIG_NO_PATH_MTU_DISCOVERY is not set
# CONFIG_TCP_NAGLE_OFF is not set
CONFIG_IP_NOSR=y
CONFIG_SKB_LARGE=y
CONFIG_IPX=m
CONFIG_IPX_INTERN=y
CONFIG_ATALK=m
# CONFIG_AX25 is not set
# CONFIG_BRIDGE is not set
# CONFIG_NETLINK is not set

#
# SCSI support
#
CONFIG_SCSI=y
CONFIG_BLK_DEV_SD=m
CONFIG_CHR_DEV_ST=m
CONFIG_BLK_DEV_SR=m
CONFIG_CHR_DEV_SG=m
# CONFIG_SCSI_MULTI_LUN is not set
# CONFIG_SCSI_CONSTANTS is not set

#
# SCSI low-level drivers
#
# CONFIG_SCSI_ADVANSYS is not set
CONFIG_SCSI_AHA152X=m
CONFIG_SCSI_AHA1542=m
CONFIG_SCSI_AHA1740=m
# CONFIG_SCSI_AIC7XXX is not set
# CONFIG_SCSI_BUSLOGIC is not set
# CONFIG_SCSI_DTC3280 is not set
# CONFIG_SCSI_EATA_DMA is not set
# CONFIG_SCSI_EATA_PIO is not set
# CONFIG_SCSI_U14_34F is not set
# CONFIG_SCSI_FUTURE_DOMAIN is not set
# CONFIG_SCSI_GENERIC_NCR5380 is not set
# CONFIG_SCSI_IN2000 is not set
# CONFIG_SCSI_PAS16 is not set
# CONFIG_SCSI_QLOGIC is not set
# CONFIG_SCSI_SEAGATE is not set
# CONFIG_SCSI_T128 is not set
# CONFIG_SCSI_ULTRASTOR is not set
# CONFIG_SCSI_7000FASST is not set
# CONFIG_SCSI_EATA is not set
# CONFIG_SCSI_NCR53C406A is not set
CONFIG_SCSI_PPA=m
# CONFIG_SCSI_AM53C974 is not set

#
# Network device support
#
CONFIG_NETDEVICES=y
CONFIG_DUMMY=m
# CONFIG_EQUALIZER is not set
# CONFIG_DLCI is not set
CONFIG_PLIP=m
CONFIG_PPP=m
CONFIG_SLIP=m
# CONFIG_SLIP_COMPRESSED is not set
# CONFIG_SLIP_SMART is not set
# CONFIG_NET_RADIO is not set
CONFIG_NET_ETHERNET=y
# CONFIG_NET_VENDOR_3COM is not set
# CONFIG_LANCE is not set
# CONFIG_NET_VENDOR_SMC is not set
# CONFIG_NET_ISA is not set
# CONFIG_NET_EISA is not set
# CONFIG_NET_POCKET is not set
# CONFIG_TR is not set
# CONFIG_ARCNET is not set

#
# ISDN subsystem
#
# CONFIG_ISDN is not set

#
# CD-ROM drivers (not for SCSI or IDE/ATAPI drives)
#
# CONFIG_CD_NO_IDESCSI is not set

#
# Filesystems
#
CONFIG_QUOTA=y
CONFIG_MINIX_FS=y
# CONFIG_EXT_FS is not set
CONFIG_EXT2_FS=y
# CONFIG_XIA_FS is not set
CONFIG_FAT_FS=y
CONFIG_MSDOS_FS=y
CONFIG_VFAT_FS=y
# CONFIG_UMSDOS_FS is not set
CONFIG_PROC_FS=y
CONFIG_NFS_FS=y
# CONFIG_ROOT_NFS is not set
CONFIG_SMB_FS=m
CONFIG_NCP_FS=m
CONFIG_ISO9660_FS=m
# CONFIG_HPFS_FS is not set
# CONFIG_SYSV_FS is not set
# CONFIG_AFFS_FS is not set
# CONFIG_UFS_FS is not set

#
# Character devices
#
CONFIG_SERIAL=y
# CONFIG_DIGI is not set
# CONFIG_CYCLADES is not set
# CONFIG_STALDRV is not set
# CONFIG_RISCOM8 is not set
CONFIG_PRINTER=m
# CONFIG_BUSMOUSE is not set
CONFIG_PSMOUSE=y
# CONFIG_82C710_MOUSE is not set
# CONFIG_MS_BUSMOUSE is not set
# CONFIG_ATIXL_BUSMOUSE is not set
# CONFIG_UMISC is not set
# CONFIG_QIC02_TAPE is not set
# CONFIG_FTAPE is not set
# CONFIG_APM is not set
# CONFIG_WATCHDOG is not set
# CONFIG_RTC is not set

#
# Sound
#
CONFIG_SOUND=m
# CONFIG_PAS is not set
CONFIG_SB=y
# CONFIG_ADLIB is not set
# CONFIG_GUS is not set
# CONFIG_MPU401 is not set
# CONFIG_UART6850 is not set
# CONFIG_PSS is not set
# CONFIG_GUS16 is not set
# CONFIG_GUSMAX is not set
# CONFIG_MSS is not set
# CONFIG_SSCAPE is not set
# CONFIG_TRIX is not set
# CONFIG_MAD16 is not set
# CONFIG_CS4232 is not set
# CONFIG_MAUI is not set
# CONFIG_AUDIO is not set
# CONFIG_MIDI is not set
# CONFIG_YM3812 is not set
# CONFIG_SMWAVE is not set
SBC_BASE=220
SBC_IRQ=9
SBC_DMA=1
SB_DMA2=5
SB_MPU_BASE=0
SB_MPU_IRQ=-1

#
# Kernel hacking
#
# CONFIG_PROFILE is not set

That's all. really.


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.069 / U:3.504 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site