lkml.org 
[lkml]   [1996]   [May]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectPPPd doesn't initialize the port

Hi,

I am running linux 1.2.8 , and pppd 2.1.2 .

It seems that there is something wrong whenever the machines reboots, as you can't get the
port eg. /dev/cua2 initialized for modem usage with the chat script , regardless of the modem
or the port . I tried several ways , didn't work . The workaround is to start minicom
first , then exit with no initialize, then it will , chat , start to work properly .
What happens , is that as soon as you reboot, you can talk to the modem , but chat will not
be able to receive any answers from the modem :-(
So minicom seems to initialize the port (this has nothing to do with modem , as I didn't
turn the modem off or init it ) and accept answers from the modem , which wasn't the case
when I rebooted the machine .

I am looking for a c script that will just initialize the serial port as minicom , then exit
is it available anywhere ? If not , where can I look for more info . in doing such a script .

(I am not sure if this problem has been solved with the latest versions of pppd, the
kernel, or chat as I still running 1.2.8 )

TIA,

Deya

-------------------------------------------------------------------------
Deya Motawie Tel(O): (015) 414130
School Of Computing Science. Fax : (02) 5645341
UTS - Msc Researcher AI Lab. Email : Dhmotawi@Socs.uts.edu.au
University Of Technology, Sydney P.O. Box 123, Broadway NSW 2007
APANA System Administrator
(02 ) 692-0151 (Vox) Email : Deya@Pyramids.apana.org.au
-------------------------------------------------------------------------



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.105 / U:5.856 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site