lkml.org 
[lkml]   [1996]   [May]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Kerneld woes
Date
You wrote:
>
> Hi there
>
> I've recently had my second major effort towards getting a kerneld
> system running here, and for the second time I have failed. I compiled
> 1.3.100 with the appropriate module options, and got the modules-1.3.57
> package. I made the modules I needed -- nothing great, just parallel
> printing and PPP --- and edited my rc.S script as suggested. No good.
> insmod seems to work when I load in lp.o -- but modprobe and depmod
> both start the machine trashing. Eventually I get a series of
> messages "Ouch, no kerneld for message <insert long number here>".
> I upgraded to modules-1.3.69h and tried again. No luck. I editted
> my rc.S script as suggested by the new file rc.hints, but modprobe
> and depmod both cause the machine to thrash and eventually put out
> the messages described above.
>
> Can anyone enlighten me please?
>
> Many thanks in advance
>
> Alex

Just some check-points:

- Did you run "make modules_install" after "make modules" ?

- Does kerneld run?

- Have you tried building the (optional) kdstat (in the kerneld
directory)? A "kdstat debug" will make kerneld tell you what
it is doing. A "kdstat nodebug" will make it silent again.

- What does "modprobe -c" do? Does it tell you _anything_?

Bjorn


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.060 / U:2.956 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site