lkml.org 
[lkml]   [1996]   [May]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: kernel-1.3.99: SIOCADDRT: Invalid argument
On Tue, 7 May 1996, Alfredo Sanjuan wrote:

> Hello all,
> After upgrade from 1.3.98 to 1.3.99 I get the following:
>
> # route add -net 127.0.0.1
> SIOCADDRT: Invalid argument
>
> This message don't appear in previous kernels.
> Regards

So did I... then I remembered that the network is not 127.0.0.1
The network address is 127.0.0.0

You may also need a device argument as well?

route add -net 127.0.0.0 mss 1500 lo # worked for me


BTW: the reason I copy this to the list is that even though the above did
work, the ircd now quits with a seg. fault & dumps core.
So no, Linus, the changes didn't fix the problem :(

(ircd worked in 1.3.98 if I set the mss to 1500 like above)

Or maybe the problem is fixed, and there's another bug in ircd that makes
it dump core now?
I'll recompile it under 1.3.99 (Greased Hedgehog on Jolt Cola) and see if
that makes any difference...

-- Matt



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.058 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site