lkml.org 
[lkml]   [1996]   [May]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject1.3.18 hard disk failure related to serial port?
Greetings,

In the past 6 months I've had 2 identical problems when trying to hook
up and use a terminal with my 3rd serial port. The terminal works fine,
but somehow my hard drive seems to be affected, more likely the
controller card is affected because its a serial/ide card.

Here is the problem. I hook up a terminal on Com3 and start using it
after I initialize the serial ports from the serial script. Everything
works fine, then at some point I reboot the system and it no longer echos
to the console in the rc.* scripts. the ECHO statements suddenly appear
to fail. The last thing I see on the screen is something like:

Partition check:
hda: hda1
hdb: hdb1 hdb2

VFS: Mounted root (ext2) filesystem read only
(LONG PAUSE HERE)
Adding swap <16k>...
(EXTREMELY LONG PAUSE HERE)

Login:

I then do a ps and check to make sure the scripts WERE executed, and
indeed all the daemons associated with them are up and running, but the
bootup takes forever and nothing is getting echoed from the scripts.

I've checked the device directory this time because last time
reinstalling the base installation fixed it, so I thought it was the
device modes.

I removed the agetty from the inittab and got rid of the serial
initialization but it still doesn't help. The behavior continues.

Can anyone shed some light on why this has happened? I'd really
appreciate the help. I assume that my com3 port is messing up the IDE
controller card somehow and this causes some kind of bad write to the
hard disk, but why it would no longer echo login script files is a
mystery to me...unless the echo command was affected. I've checked the
messages and syslog but bothing abnormal was logged, other than a read
overflow on the terminal I tried to hook up.

Byron


PS: This probably isn't the best place to ask for answers about this, but
this has occurred twice to me using 2 different kernels, 1 supposedly a
completely stable release. So it might be of interest to the kernel group.



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.064 / U:4.644 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site