[lkml]   [1996]   [Mar]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: aha2842 and HP IIp scanner == lockup
    > I have recently attached a Hewlett Packard ScanJet IIp SCSI scanner to my
    > Adaptec 2842 VLB controller. I compiled the latest Linux kernel (as of
    > today it is 1.3.79) and the scanner is recognized on boot-up as /dev/sgd.
    > The whole machine locks solid when accessing the scanner only solved by a
    > cold boot. I have only tried one scanning program to access the scanner
    > so far as there was only on which seemed to be made specifically for the
    > hp scanner line. The program that I am using is hpscanpbm avaliable from
    > sunsite:
    > file hpscanpbm-0.3a.tar.gz
    > It accesses the scanner, the scanner starts scanning then about half way
    > accross the scanning bed the scanner stops and my machine locks solid.
    > My guess is that the problem is in either the program hpscanpbm, the
    > kernel's generic SCSI code or the aha2842 SCSI deriver. I have not tried
    > any of the older kernels (eg. 1.2.13).
    > I am not running the scan program SUID root and it still locks the
    > machine so my guess is that it may not be the scanning program but may be
    > either one of the other two possible code related areas.
    > Has any one else had experience with this or know of any fixes?

    I've had trouble with mine, yes. I have the 2940, the one that's the same
    but without the floppy controller. When I first boot the machine and the
    SCSI BIOS does its device polling, sometimes the scanner responds, sometimes
    not. When it does, it usually will hang in there long enough to do a bit
    of scanning under Linux, but once hosed, I usually have to wiggle cables,
    cuss, reboot, reset the scanner, etc. until it works again. (But in my case
    if I remember correctly, when it got hosed it didn't hang the whole machine,
    just the hpscanpbm process and I had to kill that process). I half suspect
    the cable, and half suspect that that card is just too darn picky about
    impedances or something (I read in the SCSI howto that this card is known
    to be picky about termination moreso than others).

    I have the Win95 driver for mine as well; and with it, Win95 locks up if
    I boot with the scanner turned on. What I have to do is boot with the scanner
    off, then after Win95 comes up, turn on the scanner, and restart Windows
    (without restarting the whole machine). I guess that gets the BIOS out of
    the picture, or something like that. At any rate when I do it that way the
    scanner works reliably, independent of whether or not the BIOS saw the
    scanner on bootup.

    I have played with the terminators at both ends too, to no avail. All I have
    on that card is the scanner, no hard drives or anything (and the only reason
    I bought the !@#$$ thing was because the hp cheesy little SCSI board that
    comes with it isn't supported at all in Linux and wouldn't work right under

    The rest of my setup:

    Dx4-100 mobo
    VL-bus 2940 SCSI controller with HP IIcx hooked to the external port
    via a brand new expensive cable from CompUSA (!)
    Scanner is terminated
    2940 has its terminator turned on in the BIOS setup program
    Linux Slackware 3.0.0 (kernel 1.2.13)
    IDE hd's and CD, with CD on its own IDE port
    Lots of other goodies that probably aren't relevant

    _______ KB7PWD @ KC7Y.AZ.US.NOAM
    (_ | |_) Shawn T. Rutledge on the web:
    __) | | \__________________________________________________________________
    * techno * Interpedia * virtual reality * quantize the universe * cyberspace *

     \ /
      Last update: 2005-03-22 13:36    [W:0.021 / U:9.124 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site