lkml.org 
[lkml]   [1996]   [Mar]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectBad SCSI Kernel Problem - 1.3.77 still broken
Date
From
On Thu, 21 Mar 1996 09:37:51 EST  Steven S. Dick wrote:

> Well, 1.3.76 didn't fix my scsi timeout problem, but it has
> at least made the memory corruption less severe. Also, the data
> copy itself feels like it is MUCH faster than it was under 1.3.75.

1.3.77 didn't fix my file corruption problem.

system: P166, 32mb, Buslogic BT-948, fast SCSI drive with one
partition (1.8gb).

i didn't get any messages in my /var/adm/debug (*.debug in
syslong.conf), or on my tty12 (also *.debug), for any of these
corruptions.

a) i tried to build a kernel and it bombed on line 160 of pgtable.h
... here are the relevant lines:

*** begin clip ***
"lock\n\t" \
"btsl $0, "SYMBOL_NAME_STR(kernel_flag)"\n\t" \
"jnc 3f\n\t" \
"cmpb "SYMBOL_NAME_STR(activeries per page directory level: the i386 is two-level, so
* we don't really have any PMD directory physically.
*/
#define PTRS_PER_PTE 1024
#define PTRS_PER_PMD 1
#define PTRS_PER_PGD 1024
*** end clip ***

b) after that i attempted to reunpack/patch the kernel:

tar -zxf linux-1.3.75.tar.gz ; patch -p -s < patch-1.3.76; patch -p -s < patch-1.3.77
4 out of 4 hunks failed--saving rejects to linux/net/ipv4/tcp_input.c.rej

c) deleted the tree, reexecuted the above and got no messages.
compiled the kernel. booted with the kernel. worked fine.

thanks,
-- garth


\
 
 \ /
  Last update: 2005-03-22 13:36    [W:0.039 / U:1.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site