[lkml]   [1996]   [Mar]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Diald doesn't work with 1.3.72
    Eric Schenk writes:

    > Kevin Buettner <> writes:
    > >I have been unable to get either diald-0.11 or diald-0.12 to work with
    > >linux kernel 1.3.72 (built with IP forwarding, firewalling, and
    > >masquerading). OTOH, diald-0.11 is working well with 1.3.70 and several
    > >earlier versions in the 1.3.X series (configured the same).
    > Are you making active use of all these features? I've got diald
    > running with 1.3.72, but I don't have IP forwarding turned on,
    > and although I have firewalling and masquerading compiled, I'm
    > not actually using them. If you can isolate which feature
    > is causing the problem it would probably help me track this down.

    I rebuilt 1.3.72 and disabled network firewalling, IP forwarding,
    IP firewalling, and IP masquerading. (All of these were enabled in
    the previous version of 1.3.72 that I reported on.)

    I tried out diald-0.11 (which works well for me in 1.3.70) and diald-0.12
    with this new kernel configuration and got the same results.

    Which are... diald connects, but once connected, I do not get connectivity
    via rlogin or telnet. (But I sort of do with ping. See below.)

    If I delete and then add back the default route to go straight to ppp0
    instead of sl0, then things work fine until diald decides that no packets
    have gone through in a while and shuts down the link.

    Prior to deleting and adding back the route, I pinged my service
    provider and got partial connectivity. For a while only the even
    numbered sequence numbers where returning. Then there'd be periods
    where I'd get several sequence numbers in a row properly followed
    by a bunch of missed sequence numbers. (I also noticed similar
    behavior though when using the previous 1.3.72 with IP firewalling/
    forwarding/masquerading enabled. I just forgot to report it.)


    I did a diff -u on drivers/net/ppp.c in 1.3.70 and 1.3.72. It turns out
    that the diff is over 1900 lines long! Now I'm not saying that that is
    where the problem lies, but that is a large number of changes. (What
    was that I heard about a code freeze?)


    I played around some more with diald-0.12 in 1.3.70. I had first tried
    it back in the days (not that long ago) when it would hang the kernel
    on disconnecting. I had heard that it no longer does this (which is
    true for me). But it still doesn't work properly: diald-0.12 will connect
    properly and I get connectivity, but when I watch what is happening with
    dctrl, after the connection is made it doesn't seem to see any of the
    packets going through and eventually the connection is dropped.

    Also, I have not been succesful at getting the "reroute" option to work. I
    expected the default route (as displayed by "netstat -r") to change to the
    ppp0 device instead of going to sl0, but this does not happen. Perhaps I
    misunderstand the intent of the reroute option?


    I'll conclude by saying (to Eric) that I think diald is a nice piece of
    work and I am appreciative of all the time you've put into it.

    Let me know if I can be of further assistance,


     \ /
      Last update: 2005-03-22 13:36    [W:0.020 / U:2.248 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site