lkml.org 
[lkml]   [1996]   [Dec]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ldconfig

On Fri, 20 Dec 1996, Sebastian Benoit wrote:

>
> On Wed, 18 Dec 1996 ian@greywolf.mail.net wrote:
> > Andrew Pollard writes:
> > I found another bug with ldconfig v1.8.5. It seems that when you link some
> > libraries (or try to redo the cache file), it outputs the following:
> >
> > libforms.so.0.81 => libforms.so.0.81
> >
> > This, of course, is completely wrong. It should output:
> >
> > libforms.so.0 => libforms.so.0.81
> >
> > (This is just an example, its actually occuring with this and other libraries
> > in the form .so.3.x and .so.2.x too.) That means, the "major version" link
> > never gets created and loaded in the cache, and programs that are looking for
> > that "major version" link can't load the library, and fail to run.
> >
> > Any ideas?
> >
> > Ian
>
> THIS is a real problem, and the reason I'm not using 1.8.5 !
> It seems to be a 'feature' of ld.so 1.8.5 ... :(
>

It's because the libraries are inconsistant. For instance, the ncurses
people got the bright idea to name their libraries things like, "1.9.9e."
The problem is, they tell the system to link that to "3.0." This is fixed
by renaming the actual library to 3.0 from 1.9.9e. Libforms and such are
fixed the same way. In all fairness, the ncurses "1.9.9x" naming scheme is
rather annoying, but then again, I don't really expect them to fix it.

Here's my output of `ldconfig -v`.

ldconfig: version 1.8.5
/usr/local/lib:
libreadline.so.2 => libreadline.so.2.0.0
libz.so.1.0.4 => libz.so.1.0.4
/usr/X11R6/lib:
libXpm.so.4 => libXpm.so.4.7
libPEX5.so.6 => libPEX5.so.6.0
libXtst.so.6 => libXtst.so.6.1
libXi.so.6 => libXi.so.6.0
libXIE.so.6 => libXIE.so.6.0
libXaw.so.6 => libXaw.so.6.1
libXmu.so.6 => libXmu.so.6.0
libXt.so.6 => libXt.so.6.0
libXext.so.6 => libXext.so.6.1
libSM.so.6 => libSM.so.6.0
libICE.so.6 => libICE.so.6.0
libX11.so.6 => libX11.so.6.1
/usr/i486-linuxaout/lib:
libdb.so.1 => libdb.so.1.85.1
libvga.so.1 => libvga.so.1.2.9
/usr/openwin/lib:
/usr/lib:
libnewt.so.0 => libnewt.so.0.6
libslang.so.0 => libslang.so.0.99.33
libpanel.so.3.0 => libpanel.so.3.0
libncurses.so.3.0 => libncurses.so.3.0
libmenu.so.3.0 => libmenu.so.3.0
libform.so.3.0 => libform.so.3.0
libbfd.so.2.7.0.3 => libbfd.so.2.7.0.3
libopcodes.so.2.7.0.3 => libopcodes.so.2.7.0.3
libgpm.so.1 => libgpm.so.1.09
libdb.so.1 => libdb.so.1.85.4
libgdbm.so.2 => libgdbm.so.2.0.0
libdb.so.2 => libdb.so.2.0.0
libstdc++.so.27 => libstdc++.so.27.1.4
libg++.so.27 => libg++.so.27.1.4
libvgagl.so.1 => libvgagl.so.1.2.10
libvga.so.1 => libvga.so.1.2.10
/lib:
libX11.so.6 => libX11.so.6.1
libvga.so.1 => libvga.so.1.2.10
libpam.so.0 => libpam.so.0.50
libdl.so.1 => libdl.so.1.8.5
libtermcap.so.2 => libtermcap.so.2.0.8
libm.so.5 => libm.so.5.0.7
libgdbm.so.1 => libgdbm.so.1.7.3
libcurses.so.1 => libcurses.so.1.0.0
libc.so.5 => libc.so.5.4.17
libe2p.so.2 => libe2p.so.2.1
libss.so.2 => libss.so.2.0
libext2fs.so.2 => libext2fs.so.2.0
libcom_err.so.2 => libcom_err.so.2.0
libc.so.4 => libc.so.4.7.6
libm.so.4 => libm.so.4.6.27
libcurses.so.0 => libcurses.so.0.1.2




--
Good government. Good government. Sit. Stay.


\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.080 / U:0.588 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site