[lkml]   [1996]   [Dec]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Patch in this message
SubjectMinor patch for 2.0.27

Hi there,

I've noticed a bug in 2.0.27's README: The README says that
you need gcc 2.6.3 or newer. In fact, 2.0.27 does not compile
with 2.6.3 w/o modifications: It doesn't understand pentium
optimizations (-malign-*=2) and the compilation fails in include/fddidevice.h
on "__attribute__ ((packed))". The most simple fix is attached.


--- linux/README.orig Wed Dec 18 23:27:45 1996
+++ linux/README Wed Dec 18 23:28:00 1996
@@ -128,7 +128,7 @@

COMPILING the kernel:

- - make sure you have gcc-2.6.3 or newer available. It seems older gcc
+ - make sure you have gcc-2.7.0 or newer available. It seems older gcc
versions can have problems compiling newer versions of linux. If you
upgrade your compiler, remember to get the new binutils package too
(for as/ld/nm and company).
Jan "Yenya" Kasprzak <>
[[ ^^^ Note my new e-mail address!!! ]]
[[ Visit the Czech Linux Homepage at ]]
Only wimps use tape backup: _real_ men just upload their important stuff
on ftp, and let the rest of the world mirror it ;) --Linus Torvalds
 \ /
  Last update: 2005-03-22 13:38    [W:0.043 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site