lkml.org 
[lkml]   [1996]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectProblems with 2.1.15
Date

I appreciate everyone's input in tracking down the 2.1.15 boot problem,
and here is a run-down of everything that everyone has suggested that I should
check, and things I already knew:

1. 2.1.14 boots perfectly.
2. I do have init, it resides in /sbin/init.
3. /etc/ld.so.cache exists, and it is not corrupted.
4. I have checked init/main.c, and did a diff between it (v2.1.15) and
the one from 2.1.14. The diff is as follows:

69c69,72
< extern long pci_init(long, long);
---
> extern unsigned long pci_init(unsigned long, unsigned long);
> #ifdef CONFIG_MCA
> extern long mca_init(long, long);
> #endif
71a75
> extern void smp_setup(char *str, int *ints);
97a102,104
> #ifdef CONFIG_SCSI_IBMMCA
> extern void ibmmca_scsi_setup(char *str, int *ints);
> #endif
107a115,118
> #ifdef CONFIG_BLK_DEV_PS2
> extern void ed_setup(char *str, int *ints);
> extern void tp720_setup(char *str, int *ints);
> #endif CONFIG_BLK_DEV_PS2
257a269,272
> #ifdef __SMP__
> { "nosmp", smp_setup },
> { "maxcpus=", smp_setup },
> #endif
350a366,368
> #ifdef CONFIG_SCSI_IBMMCA
> { "ibmmcascsi=", ibmmca_scsi_setup },
> #endif
356a375,378
> #ifdef CONFIG_BLK_DEV_PS2
> { "ed=", ed_setup },
> { "tp720", tp720_setup },
> #endif
819a842,844
> #endif
> #ifdef CONFIG_MCA
> memory_start = mca_init(memory_start,memory_end);

At first glance, I don't see anything that would change the way that
init works on boot-up (i.e. the major init-running function has not been
modified)

5. The version of init I run is the latest, that being 2.62.

If anyone knows anything else that might be of imortance to why 2.1.15
refuses to boot, (it hangs after the VFS line), please let me know.

Ian

\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.034 / U:7.208 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site