lkml.org 
[lkml]   [1996]   [Dec]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Why doesn't Apache/Stronghold like Linux 2.0.x?


I've run Stronghold 1.3.2 for a long time without problems; I'm at 2.1.7
now on the Web server. I've never seen the runaway daemon problem, though
I've heard others have.

I did see far too many sockets stuck in the FIN_WAIT2 state on 2.1.13, so
I fell back to 2.1.7 and it is doing fine. P133, 64MB, 512k cache.

-- Michael

On Mon, 9 Dec 1996, Joshua M. Thompson wrote:

> In the continuing saga of those of us plauged by problems with running
> Apache 1.1.1 (or, in my case, Stronghold 1.3.2 -- same thing but with SSL
> support), I'm having some damned strange problems since I went up to
> 2.0.26/27. This problem predates my use of Stronghold (I was having it
> back when I ran plain vanilla Apache 1.1.1), so i don't think it's related
> to Stronghold.
>
> Originally, i was having the problem many others were having -- I would
> end up with httpd processes stuck in the R state, eating up huge amounts
> .....
> Now that I've gone up to 2.0.26 (And today 2.0.27, same result) I've got a
> stranger problem. Now I ended up with pretty much the same symptoms,
> except the processes are killable and they are happening MUCH more often.
> .....
> I recall that these problems started way back in the early 2.0.x days,
> possibly around 2.0.13. I vaguely recall that some changes were made to
> the handling of file locking...


\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.069 / U:1.212 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site