[lkml]   [1996]   [Nov]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subject/dev/stdXXX symlinks in RH 3.0.3 and gawk-3.0.0
Building gawk 3.0.0 I ran make check but it failed on one test.
Snooping the test I saw that a line that should have gone on
stdout actually didn't. Well, "stdout" for gawk's tests is
/dev/stdout... so here is the problem:

[redrose]/usr/new/gawk-3.0.0/test[87]# ls -l /dev/std*
lrwxrwxrwx 1 root root 17 Jun 16 22:55 /dev/stderr ->
lrwxrwxrwx 1 root root 17 Jun 16 22:55 /dev/stdin ->
lrwxrwxrwx 1 root root 17 Jun 16 22:55 /dev/stdout ->

I have RedHat 3.0.3, unless I have messed things up with
iBCS MAKEDEV I never touched those symlinks, where it is
clear that stdin and out are reversed.

The sad thing is that reversing links does not yield anything
different (EOF on the out2 file). Tried with both bash and
tcsh. Three questions:

0. Am I just late (there is a 3.0.1 gawk or so) ? If not...
1. Am I correct in exchanging /dev/stdout with /dev/stdin so
that stdout=/proc/self/1 and stdin=/proc/self/0 ? And,
2. Is the test broken ?

thanks in advance,


Linux kernel-2.1.7 libc-5.4.10 gcc-2.7.2 binutils-

 \ /
  Last update: 2005-03-22 13:38    [W:0.034 / U:3.536 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site