lkml.org 
[lkml]   [1996]   [Nov]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectSMB long filename support

Hi All!

The linux-kernel list could be the wrong place for me to
be asking this but it involves several issues and I have no clue
as to where to look next.

I am running 2.0.25 on a 486-50dx VLB with 20 megs ram, slackware
3.1, ide hard disk and ide cdrom. Nothing real special... I have
an NT 4.0 server running MacIntosh file and print services. I also
have Mac users who are complaining... (no kidding you say!) These
poor people complain that files they know are on the NT box and in
fact _are_ there simply don't show up, distressingly often.

So, I tried smbfs-0.5.tgz to mount the NT drive on the linux
box, worked well, very useful. I know that smbfs says you can't
reexport via NFS but I wondered if I could reexport with netatalk.
This would avoid having to run NFS clients on the Macs and that
awful Onnet32 NFS server on the NT box as a benefit.
I seemed to remember that ncpfs allows reexport via NFS so I
thought it reasonable to try netatalk. Incidentally, if ncpfs can
do it, why can't smbfs?

Netatalk-1.3.3 wouldn't compile for me but netatalk-1.4b2.tar.gz
did and all seemed peachy. My MacIntoshes could see the linux box
and the smb mounts to the NT box. I drag some files from the the
local drive of a Mac to the smb mount and they write with reasonable
speed. Then I drag the files from the smb mount to the trash
and they write there but I get a message from the Mac "The command
could not be completed because an error of type -50 occurred." The
files are in trash, but not deleted from the netatalk reexported
smb mount. (ah, I am not a Mac person btw) If I understand it
correctly the Mac tries to copy the files from the network to
the trash and then delete them from the network.

Also, wherever the Mac user went on the NT filesystem, it left
directories called .AppleDouble containing one 589 byte file called
.Parent and I do not know what these are, other than annoying.

Is this perhaps related to the experimental nature of the
SMB long filename support? Am I completely out to lunch and
trying to do something that I shouldn't be trying? Is it perhaps
a bug in smbfs-0.5.tgz, and if so, where would I pursue help with
that? Is it perhaps netatalks fault? (I do know where the list is
for netatalk) And what the heck is an "error of type -50" ???

Thanks all!

Lurk mode back on...

Eric Hoeltzel
sysadmin - Sitewerks Online Design
www.sitewerks.com


\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.033 / U:0.572 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site