lkml.org 
[lkml]   [1996]   [Nov]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectNFS-Root problems

I'm not sure if I'm sending this to the appropriate lists, but I'm having
a bit of trouble with an NFS-mounted root filesystem.

I have a DEC Alpha UDB with 64mb of memory running Linux 2.0.25 (with
axp-diffs from 2.0.21) and the RedHat 4.0 distribution. The machine the
root filesystem is mounted from is a Sun Sparc 20 clone running Solaris
2.5 with the recommended patch cluster from Sun Microsystems.

If I execute 'ncftp' then quit and run 'ncftp' again, I immediately get
"NFS server (ip address here) not responding." Moments later, *every*
machine connected to that same Solaris machine via NFS get the same
message. Basically, the NFS server on the Solaris machine becomes totally
unusable and locks up tighter than a drum. I can't even kill the NFS
server daemon and restart it. The only way to recover is to reboot the
Solaris machine.

This only happens when I'm using the Alpha box. I've tried a similar
setup on an i386-based machine and experienced no problems whatsoever.
I've tried Solaris 2.5 with and without the patches installed. I've even
tried different machines. The same thing happens every time. I can't
seem to produce this problem with anything other than ncftp.

Doing an strace on ncftp shows it trying to write to an flock()'ed file
called ~/.ncftp/i.am.running just as the NFS server crashes.

Has anyone else experimented with NFS-root on the Linux/axp platform?


Shane-

--
Shane DeRidder | System Admin / Webmaster | Love doesn't make
shane@together.net | Together Networks | the world go 'round,
http://blah.together.net/ | http://www.together.net/ | but it makes the
(802)860-5166 | (802)862-2030 | ride worthwhile...


\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.032 / U:2.160 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site