[lkml]   [1996]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Re[2]: 2.1.8 problems

From: Michael Nelson <>
Date: Wed, 13 Nov 1996 03:16:43 -0800 (PST)

> What UART do you have in your system?


Is the UART labelled as a National Semiconductor UART? Or is it made
by someone else?

> What UART was detected in the bootup messages?



After reading Alain's note about adding "uart 16550A" to the
invocation of setserial, I tried 2.1.9 again... now it works, now the
chat session looks exactly like the one above shown for 2.1.6.

What was the invocation to setserial like before you added "uart 16550A"
to it? And what would "setserial -va /dev/ttyS<x>" report before you
call setserial?

I have had the same rc.serial for a couple years now and never had to
use the "uart 16550A" switch for setserial before, but apparently it
is necessary under 2.1.8 and 2.1.9.

It shouldn't be, but there seems to be a number of different problems
crawling around. At least one of the problems (A) is that some non-standard
UART's are getting detected as 16750's. Another problem (B) is the irq
autodetection is failing. I'm trying to make sure that (C) the 16450
vs. 16550 problem is a real one, and not related to one of the previous
two problems. I've been able to duplicate (B), but I haven't been been
able to duplicate (C). Certainly your symtoms might be explained by the
irq field being set to zero.

I want to make sure you're not accidentally resetting the irq, and that
the 16450 vs 16550 issue isn't a red herring.

- Ted

 \ /
  Last update: 2005-03-22 13:38    [W:0.041 / U:2.316 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site