lkml.org 
[lkml]   [1996]   [Nov]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.0.25 - as errors STILL stop compile
Date
> I had this same problem with 2.7.2.1, and had to spend a huge
> amount of time reverting. This is such a fundamental problem
> that I'm really surprised that anyone has gotten it to work,
> much less is advising people to upgrade to it! Possibly it
> should have been marked as a beta version. Definitely it should
> not be required for new kernels. :/

It works very well and has fewer bugs than 2.7.0 and 2.7.2.

To install it, you must remove every last trace of the previous
version. The different versions are designed to coexist, but
they do not.


At the very least, you should remove these things from /, /usr,
and /usr/local:

lib/gcc-lib bin/cpp bin/gcc bin/c++ bin/c++filt
bin/protoize bin/as bin/cc


I'm sure I missed many things. It is best to install the new version
right on top of the old version - in /usr or /usr/local as needed.
(this stuff really belongs in /usr though)

I'd also suggest upgradeing related things at the same time.
By that I mean libc, binutils, and ld.so. That might mean you
should wipe out /usr/include even. Be sure to do all the removals
before you start to add things back.


\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.034 / U:21.416 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site