lkml.org 
[lkml]   [1996]   [Nov]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: modules 2.1.8 fix
On Mon, 11 Nov 1996, Jacques Gelinas wrote:

> Some people have reported a bug about this. The bug is that some module
> lack a bss. Here is the official patch I intend to include in the next
> release of modules-2.1.8

[patch removed]

The patch does not solve much, as insmod still segfaults on its own test,
drv_hello.o, leaving the module uninitialized. insmod from modules-2.0.0
inserts it just fine...

By the way, this is with kernel 2.0.24 - I got 2.1.8 compiled, but I
haven't rebooted yet. I'm gonna do it now...

[several minutes and an oops - solved - later :)]

It looks like it's working with 2.1.8. I tried inserting all the modules I
had, and they all got in just fine. Back to 2.0.24 for further testing...

[2.0.24]

Hmm... I guess I should have tested it more. insmod works flawlessly with
all the 2.0.24 modules that I could find, but _not_ with its own drv_hello
test module. :-)


Ionut

--
Ionut Badulescu - Columbia College '98 E-mail:ib42@columbia.edu
Phone: (212)853-7875 Snail mail: 4A4 Wallach Hall
Fax: (212)695-5560 1116 Amsterdam Ave
PGP key available on request New York, NY 10027
It is better to keep your mouth shut and be thought a fool,
than to open it and remove all doubt.





\
 
 \ /
  Last update: 2005-03-22 13:38    [W:0.078 / U:4.944 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site