lkml.org 
[lkml]   [1996]   [Nov]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: modules and 2.1.8
On Sat, 9 Nov 1996, Zephaniah E. Hull wrote:

> When trying to load modules under 2.1.8 i get
> white_star:/lib/modules/2.1.8/block# modprobe floppy
> init_module: Invalid argument
> white_star:/lib/modules/2.1.8/block#

I have sent a new modules-2.1.8.tar.gz to Linus today which fix all that
stuff. Mostly, kernel 2.1.8 is garanteed to reject any old module
utilities (it even does a printk informing you to upgrade). There were no
way that the old utilities could be compatible with the new exception
handling available since 2.1.7.

The good news is that the new utilities have these features

-They work with any kernel, be it 2.0.x or 2.1.8+ (not 2.1.7 though).
-They can be compiled on any system (with kernel source 2.0 or 2.1) and
will work on any system.
-They don't require the libc.so.5.4.x libc. They work with it obviously
also.

So there is no restriction about upgrading to modules-2.1.8. It should be
available along the kernel 2.1 source shortly.

--------------------------------------------------------
Jacques Gelinas (jacques@solucorp.qc.ca)
Linuxconf: The ultimate administration system for Linux.
see http://www.solucorp.qc.ca/linuxconf



\
 
 \ /
  Last update: 2005-03-22 13:37    [W:0.042 / U:0.792 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site