[lkml]   [1996]   [Nov]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: PPP and 2.0.24?? problems?
I get the same behavior (quietly failing) when pppd is not run setuid root.
I fixed it (at least before I switched to Debian which works out of the
box, so I recommend that you install it) with the command:

chmod u+s /usr/sbin/pppd

The other problem ("Sorry - this system lacks kernel PPP support") I have
experienced when pppd tries to start when the modem is already locked with
another pppd. This seems to be a cosmetic bug in either the kernel, or
pppd but I never bothered to find out which. This is a failure of either
pppd or the kernel to describe the actual problem, and instead defaulting
to the `lacks kernel PPP' message. I suspect it is a pppd problem though,
so you might try the ppp mailing list instead.

Erik B. Andersen Web:
2485 South State St. email:
Springville, Ut 84663 phone: (801) 489-1231
--This message was written using 73% post-consumer electrons--

wojtowij wrote:
> I'm looking for a heads up on a problem i'm having with PPP and
> 2.0.24. I recently patched up from 2.0.21 and recompiled and
> I'm having problems using ppp on the 2.0.24 kernel.
> Here's a short description of the problem. After booting 2.0.24
> (with ppp compiled in, OR built as a module) I try to run setup a
> modem ppp link. I get the "Sorry - this system lacks kernel PPP support"
> message. HOWEVER if i run the pppd straight on one of the vt's i can
> watch it try to setup a ppp link. I kill the pppd process off and
> go back to try and my scripts to setup the modem PPP link and it
> QUIETLY FAILS without the earlier message.
> Anyone else having this sort of problem? Did kernel changes break pppd?
> Or am I hallucinating?
> John

 \ /
  Last update: 2005-03-22 13:37    [W:0.086 / U:2.748 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site