lkml.org 
[lkml]   [1996]   [Nov]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectOne hour GPF in 2.0.24
    Date
     Hello again... I am running the 2.0.24 kernel and have been having
    serious problems idling. After approximately 58 minutes of no keyboard
    activity I get a general protection fault which kills off kerneld. I
    have tried everything short of hacking the kernel myself (which I
    probably should have tried), including a completely barebones kernel
    without module support, and without APM support. After the GPF, mv and
    cp have core dumped on me and many other non-pleasant situations have
    plagued me. I realize most of the development effort is going into the
    new kernels, but I am dying to have linux stable again. Below is a dump
    of my hardware followed by the /var/log/messages dump of the GPF itself.
    I would be willing to recompile my kernel all day long to test things out
    if someone can get this fixed! I apologize for the size of this email, but
    I think all information here is atleast mostly relevant:


    //
    // system config dump:
    //

    syslogd 1.3-3: restart.
    kernel: klogd 1.3-3, log source = /proc/kmsg started.
    kernel: Loaded 2792 symbols from /System.map.
    kernel: Symbols match kernel version 2.0.24.
    kernel: Loaded 43 symbols from 5 modules.
    Console: 16 point font, 400 scans
    Console: colour VGA+ 80x25, 1 virtual console (max 63)
    pcibios_init : BIOS32 Service Directory structure at 0x000fb190
    pcibios_init : BIOS32 Service Directory entry at 0xfb600
    pcibios_init : PCI BIOS revision 2.10 entry at 0xfb630
    Probing PCI hardware.
    Calibrating delay loop.. ok - 199.48 BogoMIPS
    Memory: 31212k/32768k available (508k kernel code, 384k reserved, 664k data)
    Swansea University Computer Society NET3.035 for Linux 2.0
    NET3: Unix domain sockets 0.12 for Linux NET3.035.
    Swansea University Computer Society TCP/IP for NET3.034
    IP Protocols: IGMP, ICMP, UDP, TCP
    Checking 386/387 coupling... Ok, fpu using exception 16 error reporting.
    Checking 'hlt' instruction... Ok.
    Linux version 2.0.24 (root@Fusion) (gcc version 2.7.0) #14 Wed Oct 30 23:39:32 PST 1996
    Serial driver version 4.13 with no serial options enabled
    tty00 at 0x03f8 (irq = 4) is a 16550A
    tty01 at 0x02f8 (irq = 3) is a 16550A
    APM BIOS version 1.2 Flags 0x07 (Driver version 1.2)
    Entry f000:803e cseg16 f000 dseg fdfc cseg len eff5, dseg len 0
    Connection version 1.1
    AC on line, battery status unknown, battery life unknown
    battery flag 0x80, battery life 0 seconds
    ide: i82371 PIIX (Triton) on PCI bus 0 function 57
    ide0: BM-DMA at 0x3000-0x3007
    hda: WDC AC31200F, 1222MB w/64kB Cache, LBA, CHS=621/64/63
    hdb: MAXTOR MXT-540 AT, 521MB w/256kB Cache, LBA, CHS=512/32/63
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    PPP: version 2.2.0 (dynamic channel allocation)
    TCP compression code copyright 1989 Regents of the University of California
    PPP Dynamic channel allocation code copyright 1995 Caldera, Inc.
    PPP line discipline registered.
    Partition check:
    hda:Started kswapd v 1.4.2.2
    hda1 hda2
    hdb: hdb1 hdb2 hdb3
    VFS: Mounted root (ext2 filesystem) readonly.
    Adding Swap: 12092k swap-space
    EXT2-fs warning: maximal mount count reached, running e2fsck is recommended
    Swansea University Computer Society IPX 0.34 for NET3.035
    IPX Portions Copyright (c) 1995 Caldera, Inc.
    Appletalk 0.17 for Linux NET3.035
    3c509: WARNING! Module load-time probing works reliably only for EISA bus!!
    loading device 'eth0'...
    eth0: 3c509 at 0x300 tag 1, BNC port, address 00 20 af dd 68 96, IRQ 10.
    3c509.c:1.07 6/15/95 becker@cesdis.gsfc.nasa.gov
    eth0: Setting Rx mode to 1 addresses.

    //
    // Begin message log dump of GPF:
    //

    Oct 30 23:49:00 fusion login: Idling now... (this is a fake entry)
    Oct 31 00:58:28 fusion kernel: general protection: 9000
    Oct 31 00:58:28 fusion kernel: CPU: 0
    Oct 31 00:58:28 fusion kernel: EIP: 0010:[ret_from_sys_call+133/144]
    Oct 31 00:58:28 fusion kernel: EFLAGS: 00010006
    Oct 31 00:58:28 fusion kernel: eax: 00000000 ebx: 0006b854 ecx: fffffc18 edx: 0018dfa4
    Oct 31 00:58:28 fusion kernel: esi: 0018d7d0 edi: 00000000 ebp: 00009000 esp: 0018d774
    Oct 31 00:58:28 fusion kernel: ds: 0018 es: 0018 fs: 002b gs: 0018 ss: 0018
    Oct 31 00:58:28 fusion kernel: Process swapper (pid: 0, process nr: 0, stackpage=0018b7f4)
    Oct 31 00:58:28 fusion kernel: Stack: 001095e7 00009000 001095d9 00109647 0018dfa4 0010a645 00000100 00109344
    Oct 31 00:58:28 fusion kernel: 0000001d 0018d7d0 00000000 00009000 ffffffda 00000018 00000018 00100018
    Oct 31 00:58:28 fusion kernel: 00170018 00000070 00109017 00000010 00000246 001091d1 00000000 756e6547
    Oct 31 00:58:28 fusion kernel: Call Trace: [hard_idle+55/92] [hard_idle+41/92] [sys_idle+59/112] [system_call+85/128] [init+0/604] [read_mem+172/208] [start_kernel+429/440]
    Oct 31 00:58:28 fusion kernel: Code: cf 8d 76 00 8d b4 26 00 00 00 00 89 e1 51 f7 41 38 00 00 02
    Oct 31 00:58:28 fusion kernel: Aiee, killing interrupt handler
    Oct 31 00:58:28 fusion kernel: kfree of non-kmalloced memory: 0018d83c, next= 00000000, order=0
    Oct 31 00:58:28 fusion kernel: kfree of non-kmalloced memory: 0018d82c, next= 00000000, order=0
    Oct 31 00:58:28 fusion kernel: kfree of non-kmalloced memory: 0018dd40, next= 00000000, order=0
    Oct 31 00:58:28 fusion kernel: idle task may not sleep
    Oct 31 00:58:28 fusion last message repeated 4 times
    Oct 31 00:58:28 fusion kerneld: error: exit: Identifier removed


    \
     
     \ /
      Last update: 2005-03-22 13:37    [W:0.023 / U:60.660 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site