lkml.org 
[lkml]   [2024]   [Apr]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 1/1] tracing/sched: sched_switch: place prev_comm and next_comm in right order
From
Hi Tio zhang,

On 17/04/24 15:59, Tio Zhang wrote:
> Switch the order of prev_comm and next_comm in sched_switch's code to
> align with its printing order.
>
> Signed-off-by: Tio Zhang <tiozhang@didiglobal.com>
> ---
> include/trace/events/sched.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/include/trace/events/sched.h b/include/trace/events/sched.h
> index dbb01b4b7451..a4bd4330db4c 100644
> --- a/include/trace/events/sched.h
> +++ b/include/trace/events/sched.h
> @@ -239,11 +239,11 @@ TRACE_EVENT(sched_switch,
> ),
>
> TP_fast_assign(
> - memcpy(__entry->next_comm, next->comm, TASK_COMM_LEN);
> + memcpy(__entry->prev_comm, prev->comm, TASK_COMM_LEN);
> __entry->prev_pid = prev->pid;
> __entry->prev_prio = prev->prio;
> __entry->prev_state = __trace_sched_switch_state(preempt, prev_state, prev);
> - memcpy(__entry->prev_comm, prev->comm, TASK_COMM_LEN);
> + memcpy(__entry->next_comm, next->comm, TASK_COMM_LEN);
> __entry->next_pid = next->pid;
> __entry->next_prio = next->prio;
> /* XXX SCHED_DEADLINE */

Yes, makes sense to have all previous and then the next for increased readability.

Reviewed-by: Madadi Vineeth Reddy <vineethr@linux.ibm.com>

\
 
 \ /
  Last update: 2024-04-23 12:24    [W:0.056 / U:0.304 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site