lkml.org 
[lkml]   [2024]   [Apr]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] hrtimer: Remove unused function hrtimer_hres_active
Date
Jiapeng Chong <jiapeng.chong@linux.alibaba.com> writes:

> The function are defined in the hrtimer.c file, but not called
> elsewhere, so delete the unused function.
>
> kernel/time/hrtimer.c:653:19: warning: unused function 'hrtimer_hres_active'.
>
> Reported-by: Abaci Robot <abaci@linux.alibaba.com>
> Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=8778
> Signed-off-by: Jiapeng Chong <jiapeng.chong@linux.alibaba.com>
> ---
> kernel/time/hrtimer.c | 5 -----
> 1 file changed, 5 deletions(-)
>
> diff --git a/kernel/time/hrtimer.c b/kernel/time/hrtimer.c
> index cae9d04b5584..bdaf23356d4b 100644
> --- a/kernel/time/hrtimer.c
> +++ b/kernel/time/hrtimer.c
> @@ -650,11 +650,6 @@ static inline int __hrtimer_hres_active(struct hrtimer_cpu_base *cpu_base)
> cpu_base->hres_active : 0;
> }
>
> -static inline int hrtimer_hres_active(void)
> -{
> - return __hrtimer_hres_active(this_cpu_ptr(&hrtimer_bases));
> -}
> -
> static void __hrtimer_reprogram(struct hrtimer_cpu_base *cpu_base,
> struct hrtimer *next_timer,
> ktime_t expires_next)


Can you please rename __hrtimer_hres_active() to hrtimer_hres_active()
and remove the old hrtimer_hres_active() function?

Btw. you could add a

Fixes: 82ccdf062a64 ("hrtimer: Remove unused function")

as the warning was introduced by removing the last (unused) callsite
__hrtimer_peek_ahead_timers().

Thanks,

Anna-Maria

\
 
 \ /
  Last update: 2024-04-17 16:32    [W:0.042 / U:0.748 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site