lkml.org 
[lkml]   [2024]   [Apr]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH RFC v2 6/6] blk-throtl: switch to use rq_qos
Hello,

On Sat, Apr 06, 2024 at 04:00:59PM +0800, Yu Kuai wrote:
> From: Yu Kuai <yukuai3@huawei.com>
>
> To avoid exposing blk-throttle internal implementation to general block
> layer.
..
> @@ -832,7 +832,7 @@ void submit_bio_noacct(struct bio *bio)
> goto not_supported;
> }
>
> - if (blk_throtl_bio(bio))
> + if (rq_qos_throttle_bio(q, bio))
> return;
> submit_bio_noacct_nocheck(bio);
> return;

This is a half-way conversion, right? You're adding a dedicated hook to
rq_qos and none of the other hooks can be used by blk-throtl. Even the name,
rq_qos_throttle_bio(), becomes a misnomer. I'm not really sure this makes
things better or worse. It makes certain things a bit cleaner but other
things nastier. I don't know.

Thanks.

--
tejun

\
 
 \ /
  Last update: 2024-04-12 20:11    [W:0.440 / U:0.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site